I can't seem to send my ERC20 tokens without upgrading the firmware. Any way to bypass this?


I’ve written down my seed many years ago and although I know I’m quite paranoid and I’ve probably made sure the words are written down correctly I feel insecure about it this many years later.

I tried sending my ERC20 tokens through myetherwallet, metamask, the web wallet, the desktop suite and all of them require me to update the firmware before I can send any tokens.

I really don’t want to update the firmware without absolutely knowing for 100% sure that my seed is correct.

I can’t use the check recovery seed because I don’t want to wipe my trezor (I’ve seen instruction videos on youtube were they first wipe the device) so is there any way to bypass this annoying restriction?


Hi @Alassets

you can check your recovery seed in Trezor Suite device settings.
Please note that it is just simulated check and it won’t affect your seed, there is also no need to wipe your Trezor.

Once you are sure that your recovery seed is correct you can proceed to firmware update.

But is my seed not exposed to my computer when I do that? I have a model one?

You actually have two options:

You can do standard dry-run recovery that uses your Trezor to tell you what word to enter into your computer.

Or advanced dry-run recovery that keeps words and their order isolated on your device. So you have to click the grid to navigate through words according to the location shown on your Trezor screen. (very much like when you are setting up/entering your PIN).

  1. It’s unsafe right?

  2. But i’ve read everywhere that I need to whipe my trezor before I can do advanced dry run recovery?

  3. is there a way to bypass this and send my erc20 tokens without an update?

If you’re really paranoid, you won’t be thinking that way in years.
Because you were paranoid back then, you must have used various methods to ensure that the seed phrase you recorded is correct.
For example, when I created the wallet and wrote down the mnemonic phrase, I went to the btc account and copied my payment address. Then I wiped my device and restored the wallet using the seed phrase’s advanced recovery feature. Then I compared the btc address I copied, which is exactly the same.
Then I made multiple backups of the seed phrase before I started using the wallet.

The problem is that I don’t remember what I did anymore. I have a burnout and suffer from all kinds of symptoms of which one is memory loss so I’m basically betting on how accurate my assumptions of myself are.

no, this procedure is absolutely safe.

I deny that, there is no need to wipe your device before you can do any dry-run recovery (otherwise there would be no point doing that)

Having the fw up to date is often the only way to expand the functionality of your Trezor, to apply new security measures, and to enable newly developed features so it is strongly recommended to update the firmware.

  1. You are saying it is safe but I need to type the words into my PC right? So if that is the case, how can it be safe?

  2. That’s what I thought.

  1. I understand but is there a way to bypass it FOR the short term so I can do a transaction?

Advanced recovery does not require typing any words on the computer.
advanced dry run recovery is a simulated recovery, the purpose of which is to check the correctness of the phrase of the seed.
Same as Advanced Recovery. No need to type words on the computer.
Letters, words will appear on the device screen. All you need is to click the point corresponding to the screen position on the computer screen to verify the seed word.

I’ve completed everything and it worked. Is it correct that the display design changed on the trezor ONE? The numbers look different, background of the numbers to be precise.

I’m having this same issue I can’t access any ERC20 smart contract without upgrading Firmware. It was working fine barely weeks ago and I’ve not been notified on Trezor Suite that ERC20 would no longer be supported on current 1.10.0 firmware. I haven’t got my seed to hand - is there something I can do to get round this? working fine on BTC and all other chains via Metamask


When you say that you don’t have your seed to hand, does that mean you’ve lost it? If so, you cannot do the Dry run recovery or the Advanced Dry run recovery, as MichalZ explained in post 3 above. You’ll need your seed to do that.

You still have to update your Firmware. Do this:

  • Move your funds - all coins and tokens - to another temporary place, either to another hardware wallet, software wallet, or custody wallet
  • Check that everything is moved and appear correctly in the temporary wallet
  • Do a Factory reset from Trezor Suite (Settings → Device → Danger Area)
  • Unplug and replug your Trezor
  • Set up your Trezor from the beginning and be sure to write down your new Recovery seed
  • Update the Firmware
  • Move your funds back to your Trezor from the temporary place you had them
  • Proceed with ERC-20 tokens

Thanks for the reply - but I’ve got my seed and did the dry recovery, it’s saying it’s a recognised seed but not for this device which is weird as I only have one device! I saw another thread on here with people having the same issue with seeds not being recognised only just yesterday so maybe there’s a wider issue here?

Appreciate the advice however I’ve got ERC20 coins locked up on Orion and CTSI and can’t get them out of the smart contracts as it stops the process at “Update Firmware” when I try to authorise unstaking. Not sure if Orion or CTSI could help with this if I can prove it’s my account by staking / unstaking on BSC from the same wallet address?

Also just found the same issue with needing firmware update to unstake on Matic and Moonriver chains. Absolutely crazy there were no notifications on Trezor Suite flagging this, I use TS almost every day and it just says “Update Firmware” not “Update Firmware within 10 days or you’ll lose access to ERC20, Matic and Movr chains”.

Well, if the Dry run procedure says it doesn’t recognize the seed, then either you did something wrong during the Dry run process or it is in fact another seed. Maybe it’s a seed from another wallet elsewhere, Orion maybe? It’s important to write down on the same paper, where you write your seed, which wallet it belongs to, so you know that if/when you need to use it later.

Agreed mate but I was diligent and have it in two places and both match up. It’s not so much the coins locked just not given any indication that running firmware from less than a year ago is all of a sudden not ERC20, Matic and Movr compatible. 2 weeks ago it worked fine.

Lets see what customer support say. I hope they can share what configuration changes have caused this and help rectify.

thanks again for your reply buddy i appreciate it

1 Like

Did you manage to send without updating firmware?