How I lost my address with 10 years of savings (not found yet) Trezor + MetaMask

Hi everyone. I make this post to show my story from the beginning till the end (I hope so). Maybe it can help anybody with the same issue. (and me)

I lost my address in a very similar way to many other users.

  1. Connected Trezor to MetaMask
  2. Created ETH address
  3. Sent all my assets to this address
  4. When I returned to the wallet a month later, there was no longer access to it, and after the account was deleted, the address disappeared altogether.

Last 3 weeks I did a massive research about my problem. As much as I didn’t want to admit it to myself, I created a passphrase. (still don’t believe) So it remains for me to look for what I could enter and at the same time forget about it. (unbelievable)

What I have checked so far:

  1. Firstly I sent a ticket to the Trezor support team and got back a super big mail with all information. Thank you for that.
  2. My main seed phrase is correct. I checked it through Trezor Suite (backup check)
  3. If I enter the standard wallet, then my address is not there. (without passphrase/25 world)
  4. If I enter my usual password/pin into the passphrase window, then my address is not there. I tried about 30 options in different combinations.

My next step:
I will try to pick up all possible typos in my usual passwords and pin codes.

If that doesn’t help, then I don’t know what else to do. I will keep you updated and write an update under this post. If you have any ideas on what else I can try to do - write it, please.

1 Like

Heiii @Artyom

Thank you for sharing, it lets others learn so they don’t do the same mistakes.

I to have lost funds do to badly backup or mistypo passphrases.
From this loss I became more diligent and haven’t lost again…Yet

Good luck

1 Like


  1. I’ve tried every password I’ve ever had in my life. (10 variations)
  2. I tried different combinations of my passwords. (30 variations)
  3. I found a program that checks the phrase for all possible typos. I ran all these passwords through this program. (20000 variations) It was fast check, around 20 sec.
  4. I ran 3 of my master passwords through this program with likely double typos. (307 million variations) It was not so fast check, around 4 hours.

Total of the variants of the passphrase checked: 307 020 040

Nothing. :crying_cat_face:

My next step: I will run all digital variants 0-9 up to 8 characters. It can take 70 hours.

***Parameters during the run: ***
address check: 0-1, 10
path: default


  1. Tried all possible digital PIN codes [0-9] up to 8 characters. It takes 67 hours. (111 millions permutations)
  2. Tried all possible symbol from [a-z A-Z 0-9] up to 4 characters. It takes 20 minutes. (1,3 millions permutations)
  3. I thought what if I entered MM seed phrase to the passphrase window while connect Trezor to MM? :face_with_monocle: But there are more than 50 characters, so it’s impossible. Same with Trezor seed.

Failed :crying_cat_face:

Total variants of the passphrase checked at this moment: 419 486 388

My next step:
I will run all digital variants [1-9] with 9 characters. If I typed super random PIN from the Trezor monitor it may help. It can take 82 hours.

Parameters during the run:
address check: 0-10
path: default


  1. Tried numbers [1-9] up to 9 characters. It takes 82 hours. (387 millions of combinations). It means I tried every possible pin cod (in passphrase window).

Nothing. :crying_cat_face:

Total variants of the passphrase checked at this moment: 806 906 878 (almost 1 billion! :anguished:)

My next step:
I will try all my usual pins and passwords using different derivation path: Trezor Testnets.

People, I need your help. :sleepy: What other kind of codes can be checked? Please write your options here, I will try them if it is feasible. I promise to send $300 if your option return my address back to me.

Parameters during the run:
address check: 0, 1, 10)
path: default


Just because I feel your pain,

Check this post Recovery Tools - Passphrase Recovery/Wallet Recovery

Maybe it can be helpful

Keep in mind to do your own research and use at your own risk.

I don’t know if it works with Eth

I have not tried it myself, also thanks for sharing as it helps others to learn

Good luck

Hi @Artyom,

I’m sorry to hear of your loss of funds, but I hope you find your ETH again.
You said you had a ticket with Trezor Support. Did you discuss your transaction with them, and if so, what did they advise you about it?

If you did, then your only hope is to try and remember it. But are you sure you made a Passphrase in your Trezor? Maybe it was (a password) in Metamask instead? You said above:

  1. When I returned to the wallet a month later, there was no longer access to it, and after the account was deleted, the address disappeared altogether.

… what wallet was deleted – the Metamask wallet or your Trezor wallet?
And why didn’t you have access to it anymore?

Note that a Trezor wallet connected to Metamask is not the same as a native Metamask wallet. Also, Metamask have its own seed phrase and password (often confused with Passphrase).

About the Passphrase, if that’s what you did lose, check if your web browser has stored any passwords automatically for Metamask or Trezor Connect.

Metamask password:

Trezor Passphrase in Trezor Connect popup:

1 Like

Hi! They gave me a lot of advice and explanations. What I am doing now is the result of our correspondence.

At the moment, I’m not sure of anything anymore. But the fact is that I created an address that I no longer have access to. If I try to log in without a passphrase or with a passphrase (I have already checked almost 1 billion variants). Then the first address does not shown. Of course I tried to enter MM pass to passphrase window.

I deleted “Trezor 1” in my MM. I wanted to reconnect Trezor. And after that, I still can’t find the very first address.

Yes, I know.

I checked. There are no savings for Trezor Connect. :worried:

Thank you! I already use the same program, called FixMyCrypto.


  1. I tried my usual passwords and pins using Trezor Testnets derivation path.
  2. I tried to mix my letters passwords with numbers + all possible typos. (over 20 millions) using default BIP44 Standard

Nothing… :hot_face:

Do you think it could be that with full concentration of attention, during the creation of the wallet, I agreed to a long password from Google Сhrome or Mac OS Keychain, which in the end was not preserved anywhere and I don’t remember doing this?

My next step:

  1. Maybe I need to buy a similar Trezor wallet and try to recreate the process that was in the beginning. Maybe this will recreate the problem?
  2. A hypnosis session???


If you haven’t already done so, check in your email if you’ve received a receipt from Metamask on the transaction and if the Transaction (Tx ID) is in that message? Usually you’d get a receipt when the transaction is completed.

No, I don’t have this message. Why do I need it?

I know my first address with assets.

Knowing the Tx ID may’ve lead to some answers.

I can see Tx ID from another place.
I have 10 incoming transfers and 1 outgoing. What can I check with these Tx ID?


I have a pretty good news.

My investigation led me to what I found out:

  1. The first amount of the crypt was received on October 4. On the day the Trezor wallet was created. I made this transfer from the exchange.
  2. The first and only successful withdrawal of money back to the exchange was made on October 9. 5 days later (!), after creating the account “Trezor 1” in my MM.

This means that I have entered SOMETHING into the passphrase window at least 2 times. And both times I didn’t remember it! (am I that much of an idiot?)

Considering the fact that there are no automatically created and saved passwords for Trezor Connect in my browser and in Mac OS Keychain itself, this means that I did NOT create such a password. (Thank god! Coz it is impossible to pick up a password even from 15 random characters by brute force.) Otherwise, I would not be able to enter it on October 9 to make a withdrawal.

It turns out that the options are 2:

  1. I entered some characters that I usually use for passwords. Twice (!). But then why didn’t any of them work now?
  2. I copied and pasted something that I forgot about later. (I’m a freak, at least, or I have a split personality ha-ha)

By the way! I have already found a person who can conduct a hypnosis session in which he will try to return me to the day when I entered some password. He said that the probability that it will work is small, but we can try.

So guys, if you have any ideas what else I could check, please write them below. Let me remind you that I promise to send $300 if your idea gives me access to the address.

@Artyom Nice to see you’re taking it the positive side.

Thanks for sharing your experience.

I admire your perseverance, I lost some ADA due to a wrongly written passphrase twice, the backup was also wrong I gave up after two weeks.

I cannot remember, have you tried leaving the passphrase blank?

Good luck

By looking at the adresses for incoming and outgoing transactions you can get clues about which wallet you used.

The problem here could be that these transactions went to/from a wallet you deleted. It could be that one of these wallets were a native Metamask wallet, and if you deleted that you need to restore your Metamask account with the seed you created that account with. It’s the same procedure as with a deleted Trezor wallet. Both have their unique recovery seeds (although some users use the same seed in both).

So you need to try and think back to what you deleted and where. Was it on your Trezor or in Metamask (or both), and if so, did you use the correct recovery seed to restore it? Or did you make a brand new wallet with a new seed?

I guess it’s not so easy to remember what happened and what you did when there are so many variables here, especially since so much time has passed since it happened.

I also use Metamask to swap/buy coins and transfer them to my Trezor, through a connected Trezor #1 account on Metamask, but I never use Metamask’s native account(s). This means I can delete Metamask, reinstall the plugin in another browser or computer, and never have to deal with Metamask’s recovery seed. I simply reconnect my Trezor in a new Trezor #1 account and voila, I see my Trezor wallet. It makes my life a lot easier.

Here’s where many users are mixing up wallets, accounts, and seeds. This forum is full of such cases.


Do you have your Metamask seed and your Trezor seed?

When you said (in the first post above) you came back to your wallet after a month, you couldn’t access it. Why? What type of error situation did you experience?

Did you write your full story anywhere?
Your backup with seed phrase was wrong too?

You must be kidding :smile: YES

You have published so much stuff….

I didn’t publish my story, it was long before I joined the forum and did not have a trezor and nothing special to tell.

Maid one backup on paper that didn’t work, and another on encrypted flash drive that also didn’t Got really furious with idiotic mistake, assumed my error and moved on.

I learned the lesson, haven’t lost anymore YET…

Ps: just curious what programs do you use to run all the combinations?

I deleted (removed) only “Trezor 1” wallet from my MM. I did screenshots of it before delete. So I’m sure about it. I didn’t delete MM wallets. There is not even such an option, unlike removing “hardware” Trezor 1.

No, I didn’t restore MM by the seed phrase. And I did not restore Trezor by the seed phrase.

MM was created a long time ago. There is access to MM wallets and it has not been lost.

I checked Trezor seed phrase through the backup check, everything is fine.

I understand that. I didn’t mix the seeds.

Yes, I have.

This day I still saw it as Trezor 1.
A little background story.
After 1 month I found out that it is possible to create a hidden wallet. I realized that it would be more safe. Then I connected my Trezor One. Enabled the hidden wallet option in Tresor Suite. Created a hidden wallet. After that, I tried to send the first amount from my Tresor 1 (through MM) to new hidden wallet, but I failed (freezing ring). I thought I needed to re-add it and removed Trezor 1.

When I tried to add Trezor 1 again without entering a passphrase, other addresses appeared in front of me. I have not found my first address with assets since then.


  1. I lost address from my very first Trezor 1 account. (I thought I created a standard wallet.)
  2. I have a hidden wallet, created with passphrase (in fact, I have already checked 800 thousand hidden wallets)
  3. I have a standard wallet, created 1 month later after Trezor 1. With no previous address and no money.