How do I access Suite once I downloaded it?

The trezor.io page asks me to download it and I have. I click on the download Trezor Suite appimage and am asked to choose a program to open it with since it is an unknwn file… I am on linux mint… A beginner on linux. What program could I use to open it?
Or is there an url that would take me straight to Suite ?
Somehow yesterday I accessed my Suite account and did a transaction. Then I could not figure out how to log off !
Today, I figured out the url to access the original version is Trezor Wallet
Learning curve ! From other entries, I understand at some point Trezor will do away with the original version.
Is it known when that may be? I need to figure this Suite out before ithe original is removed !
Thanks in advance for help with these questions. :))

Hi @libre,

See here: Trezor Suite, how to run

You can try the web version of Trezor Suite at https://suite.trezor.io/web

Just close the program by clicking on the X at top right. As for the device, just pull the USB cable.

There’s no date set for closing the web wallet at https://wallet.trezor.io but you can expect that to be announced before it happens and they need to consolidate all functions from the website into Trezor Suite first too, so it won’t happen anytime soon. I guess.

Petosiris,

Thank you so much! It looks like Greek to me on the How to run…
Do you use linux? I will need help following those instructions !
If you do not use linux, can you refer me to a member who does that is willing to guide me through those steps ?

Yaay, that url works ! However,it went straight to my portfolio balance even though the device is not connected. Why is that ? I closed that window and tried it again and still shows my balance with no need to sign in or use password…That is scary . What am I missing ?

Until I am comfortable using the Suite, is there any reason I cannot continue to use the original version ? Apparently Suite is safer,yet until I learn it better,it does not feel safe.
THat is good for me that it may take awhile.
Thanks again. Progress !

@libre,

Yes, I’ve used Linux daily since 2004, and used Linux Mint the last years, but haven’t had a recent install so I can’t try out the things in “How to run” just now. I’m using Windows 10 at the moment.

However, I can try to explain what you should do.

chmod u+x Trezor-Suite-21.3.1-linux-x86_64.AppImage 

… means that after you download the appimage file, you -

  1. Open a command line window. It’s called The Terminal.
  2. Write sudo su (to become super user/admin for the session) and press enter.
  3. Navigate to the directory where you downloaded the file to. Use the cd command (change directory). See UsingTheTerminal - Community Help Wiki, pt. 4. for explanation of “cd”.
  4. Copy and paste the command above into the command window.
    4a. chmod is a command to change the file permissions.
    4b. in this case to eXecute so you (the current User) can run it. See Understanding Linux File Permissions - Linux.com for more info.
    4c. the rest of the line is the filename.
./Trezor-Suite-21.3.1-linux-x86_64.AppImage
  1. This is the command you enter into the command line window to run the program. Note that you must still be positioned in the directory you downloaded the file to.
gpg --import satoshilabs-2021-signing-key.asc

gpg --verify Trezor-Suite-21.3.1-linux-x86_64.AppImage.asc
  1. The last two commands are about veryfying the validity of the file you downloaded. You should do this before running the program to check you have a legit copy that’s signed by SatoshiLabs. See here for more info about .asc verification.

  2. When you’re finished, enter exit to close the Terminal window.

Community Support personel also have Linux competence. But note that Linux is out of the scope of this forum. You should do your own research about how to use Linux. I recommend joining a Linux forum.

That’s probably because you enabled the “Remember” function. It lets you see your accounts “offline”, when you open Trezor Suite. If you turn off “Remember”, then Suite will refresh your accounts with data from the blockchain every time.

Well, the website wallet won’t be developed further so all new things will happen in Trezor Suite. I’d advice you to switch to Suite sooner rather than later, but you may use the original web wallet for now of course, if you want. You can ask here if you’re wondering about something with Suite.

3 Likes

Petosiris,

Wow. Thank you ! Yes, I had turned Remember on to see what the hidden wallets were…
Turning it off does remove my data until I use the trezor again. My asset is in the Sedgwit part.
Not sure what Sedgwit means…

So I understand #1 and #2.

3, would I enter “cd/downloads” then navigate to—Appimage ?

Or “cd/downloads/Trezor-Suite-21.9.2-linux-x86_64-Appimage” ?

Do I use quotations ?

Is it okay at this point …appimage will not open when I click on it ? (due to no known programs associated with it ? )

#4 “Copy and paste the command above into the command window.”
Is this referring to the cd entry?

It gets fuzzy to me here… Do I enter
“chmod./Trezor-Suite-21.3.1-linux-x86_64.AppImage” (without quotation marks) in terminal ?

Will I be asked questions related to which permissions, or will the above entry grant all permissions?

#5 Do enter the 2 commands separately or at same time ?

Finally, where do I find the transactions I did using Suite ?

I hope you are getting some points or credit for helping me here!
Thanks again. Libre

Yes. If the appimage is in the downloads directory, then you have navigated to it with that command.

No.

No.

The appimage won’t open when you click on it because it doesn’t have permission to run on your PC. Therefore you must use the chmod command first.

No, the chmod command.

No, one at a time.

What transactions was that? What type of coin or token was the transaction with?

I live to serve … :stuck_out_tongue: Just happy if I can help.

@Petosiris Thanks for the detailed explanation & instructions!

1 Like

Petosiris,

Thanks much for your reply. I must get up my nerve to follow the instructions…
Regarding transacions. I sent BTC using Suite the day I downloaded it. The old version does show what I sent. The Suite shows :
“No transactions… yet.
Get started by receiving transactions or buying BTC.”

Hmmm… I just realized, though I thought I used Suite, maybe , since there is more left for me to do to get it set up properly, is that is why it shows the transaction on original and not on Suite ?
Thanks !

I don’t know, it’s not much to go on. We’d need more details about the transaction you made.
But perhaps you should make a new topic about the BTC transaction problem. Please search the forums to see if any of the existing topics fit your issue and if you find one that fits post there.

Please, have a look at this post explaining different types of BTC accounts

Petosiris,

Looks like I must get suite installed pronto… I did post on linux forum. I wrote TRezor support. THey suggest a forum trezor/community - Gitter for live help, but I do not use twitter, or github or gitlab. Unsure what Matrix is…
Any suggestion as to how I could join that forum?

The support referred me to this link. Apps:Trezor Suite - Trezor Wiki

Would I be able to post that first command after I download the latest Suite (deleted the October one) and avoid doing the super user and getting into my download folder?

Are you available to help on this?
If not, any other linux user that is willing to guide me on this?
Thanks.

Sorry, I’ve never been there myself.

The process should be pretty straight forward explained in this thread. You’d have to be a super user when issuing the commands though.

Petosiris,

Thanks for replying. The super user idea is intimidating to me, but if that is what it takes…
Before I do this, I want to list the steps as I understand them, so you can correct anything I misunderstood.
#1 enter command “sudo su” minus quotes

#2 enter command “cd/downloads” minus quotes
That brings me into download folder. I am trying to picture how that works…To get to the appimage file, will I need to use the commands " To navigate up one directory level, use"cd …"
To navigate to the previous directory (or back), use"cd -" ?
How do I end up on appimage ? This part is confusing to me.
Will the download file show on the terminal?

#3 enter chmod u+x Trezor-Suite-21.12.2-linux-x86_64.AppImage

#4 While still in downloads / in terminal? on my screen behind terminal?
enter ```
gpg --import satoshilabs-2021-signing-key.asc

#5 enter gpg --verify Trezor-Suite-21.3.1-linux-x86_64.AppImage.asc

#6 look for “Good signature from statement”
on both #4 and #5

Thanks in advance for your help on this Petosiris .
Libre

#0 open a Terminal window

#1 enter command “sudo su” minus quotes

Correct. sudo is the super user command sudo su sets the user to su aka the super user, so you don’t have to issue “sudo” in front of all the following commands. A super user in linux is basically the same as Admin in Windows.

#2 enter command “cd/downloads” minus quotes

Use a space between the cd command and the path. Beware that a forward slash always begin at the root, so cd /downloads will tell the change directory command to look for a directory called downloads directly beneath the root. What you probably want to do instead is changing to your Downloads directory (notice the capital D) under your home directory, like this:

cd Downloads

or

cd /home/username/Downloads (replace username with your own username)

These two commands do the same thing.

How do I end up on appimage ? This part is confusing to me.

The appimage file is downloaded to your default download directory (directory is the same as a folder in Windows), so if you haven’t changed it to something else it should be Download.

Will the download file show on the terminal?

try dir -1 to see what’s in the directory you’ve landed in. The dir command lists all the files in that directory/folder. If you can’t see the appimage file, you’re in the wrong directory.

#3 enter chmod u+x Trezor-Suite-21.12.2-linux-x86_64.AppImage

Correct.

#4 While still in downloads / in terminal? on my screen behind terminal?
enter ```

No, where did you get those ``` from? The correct is:

#4 While still in directory Downloads

gpg --import satoshilabs-2021-signing-key.asc

Correct.

#5 enter gpg --verify Trezor-Suite-21.3.1-linux-x86_64.AppImage.asc

Correct.

#6 look for “Good signature from statement”
on both #4 and #5

Maybe, I haven’t checked what the right status message is in the manual, but it should indicate success in both instances and not report an error.

Don’t forget to run the appimage file:

#7 ./Trezor-Suite-21.3.1-linux-x86_64.AppImage

And then exit the super user mode:

#8 exit

At last, close the terminal with another exit command:

#9 exit

Petosiris,

Wow. Thank you for being so detailed. Okay, I am fine on #1and #2 ;

Do I need to enter dir -1 ? Or is that just if I do not see the app image?

Are there 2 spaces before the hyphen or just one?

How do I then navigate to app image ?

Can I just click on it before entering the chmod command?

#4 On this step, I meant to paste the ./Trezor-Suite-21.3.1-linux-x86_64.AppImage command.

What if I just do #1 , #2 and dir -1 to see what the directory even looks like?
Then, if I am unsure on how to get to my downloaded app image ,is it okay if I do the command “exit” twice until I ask you about it?
Or would it be better to leave that terminal sit until I get back to it ?
Thanks !
Libre

You don’t need to, only if you want to see what’s in the directory.

One. But you can have two also, of you want.

With the cd command. See above.

No, the Terminal isn’t a graphical interface.

You may do that.

You can exit the Terminal any time you want by using exit twice.

If anything is unclear I’d advice you to read about Linux commands and the Terminal. There are tons of examples and guides your there in google land. Also, it’s advisable to join a Linux forum so you can ask other people. This forum is about Trezor hardware wallet, not Linux, so it’s limited how much I can help you with Linux itself. You should do your own research on this.

Petosiris,

I hear you.I am on a linux forum, The post on there did not say I needed to use sudo su on this… I also wrote TRezor support, but waiting for a reply.
I ran into a problem… I will post here the terminal.
What should ny next command be to fix the sandbox issue?
Do I go ahead and do exit twice now or leave terminal as it is…
Again, I thank you so much for your help on this !

[email protected]:/home/maggie/Downloads# chmod u+x Trezor-Suite-21.12.2-linux-x86_64.AppImage
[email protected]:/home/maggie/Downloads# ./Trezor-Suite-21.12.2-linux-x86_64.AppImage
[1219/132051.036922:FATAL:electron_main_delegate.cc(298)] Running as root without --no-sandbox is not supported. See 638180 - chromium - An open-source project to help move the web forward. - Monorail.
Trace/breakpoint trap (core dumped)
[email protected]:/home/maggie/Downloads#

Well, you never told me you logged in as root.

  1. This is not advisable. You should login as maggie or another normal user instead.
  2. You don’t need to use sudo su when you’re already a root user.

As I said before, you can close the Terminal window by using exit twice. Then reboot and log in as maggie or another normal user.

Then you should wait for reply from them. I can’t interfere in a Support issue, but only say that you should post your Ticket ID as a separate post here, so Support can link your case to this thread.

Happy to help! Good luck! :+1:

Petosiris.

The #1 command was to enter sudo su. Is that correct ?
Is that what logged me in in as root ?
I followed each step I thought…

$ sudo su
[sudo] password for maggie:
[email protected]:/home/maggie# cd Downloads
[email protected]:/home/maggie/Downloads# dir -1

Have I done any damage with what I did ?
Did I change anything so far ?
Or will exit now mean there were no changes from what I did?

It could be awhile,especially with the holidays, before support replies to me…

How do I link to this thread in a new post where I give the support case # ?

Thanks.

Sorry, I can’t interfere in an ongoing Support case, Libre.
Please write your Ticket ID as a separate post in this forum thread, so Community Support can link your case to it.