How can I check hidden wallet recovery

Today I wiped my laptop to a clean OS. Reinstalled trezor-suite and opened my Model T as usual. But all my hidden wallets were empty. This was a very terrifying moment.

I remembered I had backed up the old hard drive so I replaced ~/.config/@trezor with the old backup directory. My hidden wallet balances are back!

To be honest I have not tried putting the other @trezor directory back in to see if the addresses were the same or different. To find out if it was somehow a network bug or actually generating differently.

I’m happy to do it and see if there is potentially a bug. But now I’m terrified of changing things. I need peace of mind that I can recover my hidden wallets without trezor-suite.

I know trezor-suite offers a backup test and I could also use an offline wallet. But is there any software I can use to check my hidden wallets as well? It’s my crude understanding the passphrase serves as a 13th or 25th extra word in the generation but I don’t actually understand the algorithm. Any help appreciated.

Hi @samadhi,

do I get it right that you have your hidden wallets “remembered”?

If so, you most likely only copied information about these remembered hidden wallets to your new installation. It is important to understand that remembered wallets are watch-only. You will need to enter your passphrase once you want to send some funds out of these wallets.

As you mentioned, recovery seed can be easily checked, the information on how to do it can be found in this article:

for Trezor Model One:
for Trezor Model T:

If the recovery seed stored in your Trezor matches your recovery seed backup, you need to enter the correct passphrases to access your hidden wallets. Passphrase can be also easily checked, if you enter it correctly you will access the desired wallet, if not (if you enter a different passphrase), you will access an empty (different) hidden wallet. Every different passphrase creates in combination with recovery seed a different wallet with different addresses (passphrase no.1 = wallet no.1, passphrase no.2 = wallet no.2, etc…)

You can read more about passphrase here:
and also in this post on our Trezor Blog: Passphrase — the Ultimate Protection for Your Accounts | by SatoshiLabs | Trezor Blog

Yes I guess I should have been more clear. I opened the newly installed trezor-suite and typed in my hidden wallet passphrases as normal. The wallets came up as empty until I swapped out the @trezor directory. Then when I typed in the passphrase they had funds like normal.

I’ve been a software engineer in cryptography/currency for almost 10 years so I do understand what it means for the passphrase to be part of the key.

I’d be happy to undo and test it again but I’m just concerned until I can be sure I’m able to recover my hidden wallets without trezor-suite.

If it’s truly just adding a 13/25th word to the seed phrase then surely there’s an offline tool out there to try that?

First, I would like to mention that Trezor Suite is not important, it is only a SW interface that allows you to display the information about your wallet and perform actions with your private keys (represented by the combination of recovery seed and passphrase). Your recovery seed is stored in your Trezor device. A passphrase is not stored anywhere.

If you want to make sure that you can recover your wallet with your recovery seed and passphrase without Trezor, you would need to enter your recovery seed and passphrase into some other device/SW app. I would like to mention that entering the recovery seed and passphrase into SW app is definitely not recommended for obvious reasons (recovery seed and passphrase would become digitalized and you would lose the main advantage of HW wallet). If you want to test it, I can recommend testing it with a different HW wallet. However, you can be sure your wallet can be recovered with the combination of recovery seed and passphrase, it was already tested countless times before by other users. The public-key cryptography ensures it generates always the same result even when using different interfaces (such as Trezor Suite, MEW, MetaMask, Exodus…)

From your description, I think I understand what happened in your case. Most likely you did not have accounts with your funds enabled right after you installed Trezor Suite, that is why your wallets were empty. After you copied the data from the “@trezor” folder, the accounts became enabled and you could see the desired balances. Simply put, you just copied the information about what accounts (ETH, LTC, etc…) need to be enabled. There is no need to worry, these accounts can be also enabled manually, for more information check these articles:

1 Like