Failed Update from 1.9.3 to 1.10.3

Never had an issue until today when I was prompted to do a firmware update. Update appeared to jump to about 20 percent instantly then just sat there for hours. Pulled it, plugged it back in and was prompted to install Suite. Installed Suite and now the Trezor it appears blank or empty. Tried the update again and still nothing. It just sits there.


Hi @21BY34,

May I ask if you have a Trezor Model One or Model T? If you have Model One, please try the Trezor website at to update the firmware instead of Trezor Suite.

If the device failed during Firmware update, it may’ve wiped your Trezor (as a security precaution) and a Recovery may be necessary.

I have the One. When I go to that address it takes me to a page to install the suite. When in the suite and selecting update, I get to a window that says Install Firmware. Current Version → New Version. There is no progress bar or anything that gives the impression anything is happening. It sits like this for quite some time then it times out.

Hi @21BY34

Please, try it again by following properly as suggested:

  1. Before you plug in Trezor to your computer, hold both buttons pressed

  2. While still holding both buttons pressed, connect Trezor to your computer

  3. Once, you successfully enter bootloader mode, you will see Trezor displaying something like this

If you won’t succeed for the first time, don’t give it up and keep trying.

Once you enter bootloader mode, access Trezor Wallet from and you will see a screen like shown below with an option to update firmware. Before you proceed with updating, please make sure you have you recovery seed. Optionally, you can reset device. However, this option will erase all data from the device and then you will need to install firmware again.

Ok, well I have done this a dozen times now all with the same result. This last time I did it with a fresh reboot of the pc.

  1. First is what my Bootloader looks like,
  2. Then I launch the Trezor Wallet link
  3. Then what happens

It sits at that last screen forever. If after an hour or two I unplug it I see an initialization error message that quickly flashes on the screen.

NOTE, I have been able to unplug and plug it back in, log into it and still see my Bitcoin.

2 questions.

  1. Outside of a security update, any reason to do this update?
  2. If I were to purchase another hardware wallet, any if for any reason I couldn’t log into this anymore, would I be able to recover my coins via the new wallet?

I should also mention I can’t even do a reset of the device. It just sits there “initializing”.

Please, make sure to check the following:

  • After successful installation of Trezor Bridge, you should see “trezord” process running in your activity/system/task monitor. If you cannot see the process running in the background, please try to reinstall it again, from this source Trezor Wallet
  • Use supported browsers only. Either Chrome or Firefox, also try both in Incognito/privacy mode as well.
  • Clear you browsers cache.
  • Not only using a VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.
  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.

From Firmware Changelog: 1.10.3 for Model 1

  • Added: Re-enabled Firo support #1767
  • Changed: Emulator properly waits for IO without busy loop #1743
  • Removed: Lisk support #1765
  • Fixed: Add new rpId to Binance’s FIDO definition. #1705

First, let’s see if we can troubleshoot your issue.

Second, you don’t have to be worried about your funds as long as you have your seed and passphrase (if enabled and used).

If your Trezor device is lost, not working etc. (or SatoshiLabs shuts down a business), you can recover your wallet easily by using any compatible app, or any other hw wallet following BIP-39. See some compatible third-party apps Apps - Trezor Wiki. This process can be reproduced with the same result at any time, even offline. You can simply recover your wallet by using your recovery seed (and passphrase) with any other compatible hardware wallet / app when it’s needed.

Thanks for all the ideas. Unfortunately none worked. I tried it on my laptop and that did work. Seems the update was stopping where you needed to push the right button on the Trezor to start the update. That screen did show up on the laptop and selecting it completed the update.