ERC-20 coins cant send

I made seperate default accounts for Matic and Link. It shows I have recieved the coins I cant send, shows 0 no ETH not enough funds.

Help please.

Hi @Jay1,

You need to have funds in your Ethereum (ETH) “mother” account for the tokens, for the transaction fee too before you can send the token.

I do have ETH it is in the 1st default account ETH 1. Is that the mother account? Cant be cause it shows zero where matic ETH 2
Was looking to transfer from ETH1 to ETH2 using matic address (ETH 2) but within Trezor also not possible.
What do I need to do? transfer more ETH from exchange to Trezor to ETH 2?

The ETH “mother” account is the one which the token is sorted under. You can check that by going to Accounts → ETH → Tokens. So if the token you work with is sorted under ETH 2 then you need funds in ETH 2 to cover the fee.

Yes, or from your ETH 1 or ETH 3 accounts, if you have funds there.

Super thank you so much finally getting some answers, Ive been at it all day.
I did try to get ETH across from ETH1 to ETH2 couldn’t find a way to do that. Do you have the answer?

You just generate a Receive address in your ETH 2 account and use that address in your ETH 1 account’s Send address. Remember that a transaction fee also needs to be drawn from ETH 1 so don’t send everything to ETH 2.

Tip: You may also buy ETH directly from Trezor Suite, using Invity which is built in.

And you’re welcome! Good luck! :slight_smile:

Wow didn’t think of that. Your brilliant!

Tried to send but only gave me fiat options.
Me just stupid as the fiat was only there for the conversion.


1 Like