Can't execute bulk-list transactions on Opensea

Attempting to bulk-list 3 or more NFTs (same issue with ERC-721s and ERC-1155s) on OpenSea from a Trezor wallet ( After signing on Trezor, I receive the following error message in wallet: “Transaction Rejected: Firmware Error”.

This is the only scenario where I receive this kind of error, and if I attempt the same listing approach using a non-Trezor (hot wallet) there are no errors.

Have tried through 3 different wallets (Metamask, Rabby, and another) all with the same error.

My Model T is running firmware version 2.6.4.

My guess is that because there are multiple messages being signed at once (since this error doesn’t occur if using the bulk-list feature for 1 or 2 NFTs), the Trezor hardware device can’t handle this volume of data. Ledger does not have this same issue.

Is there a fix for this?


1 Like

Can someone from the Trezor team provide support on this please? It has been ongoing for months without resolution.

1 Like

Is there a more reliable way to get support from Trezor?

Update: Trezor support have indicated this has been a known issue for >1 year and have no immediate plans to address it, stating “Q3 2024 at the earliest” despite clearly no prioritization in this their github (search Trezor firmware issue #2963, since I can’t post links here :expressionless:)

This is not an issue with competitors, like Ledger.

Extremely disappointing from Trezor. :-1: