Can't connect on phone

I posted a message in November to check I could set up a trezor on a phone/tablet before purchase and was told I could though the message has disappeared now. It was here

So I had two trezors sent out to me, followed the instructions. I plugged in the Trezor, loaded chrome, went to the web app address. It says connect TREZOR but the connect button is greyed out. Not sure what fo do now :frowning:

1 Like

find Trezor —— Trezor —— begin to set


Found trezor. Connected. It told me to download bridge, which doesn’t have a mobile option.

There should be no such prompt on the phone. Can you post a screenshot of the phone operation?

there is no bridge for mobile, it works straight away via web version with webUSB, make sure you are using Chrome, try incognito mode and use cable that transmits data.

For mobile phones, the trezor can only be used with Google Chrome on Android phones.

Tried everything. Lastest Chrome version, incognito and normal, with and without vpn. I’m using the cable I ordered direct from the manufacturer. Tried both phone and tablet. Can’t get past it.

“Your device is connected properly but your internet browser cannot communicate with it at the moment. You will need to install bridge.”

There’s a link to check the status of bridge, which leads to the retused to connect.

What model is your phone?

My phone is Redmi S2 running Android 8.1.0 and my tablet is Galaxy Tab A (8", 2019) model sm-t295 running Android 9.

My phone is running Android 11 and using Google Chrome to interact with the trezor works fine.
Wait for me to experiment with the lower version of the Android phone at home and then restore you.

Android 6.0.1 works fine.

I think the biggest possible problem should be the cable. Not sure what kind of cable you are using. Some cables can only be used for charging and do not support data transfer. You can upload a photo of the cable.

It’s the little black cable that I ordered directly from when I ordered the two trezors and they all came together. I’ll check it with usb memory later when I get home and upload a photo either way, plus check another lead. Stand by…

Ok, it’s not possible to otherwise test the lead. But if it came from Satoshi it can’t be the wrong one, right? They don’t do a ‘charge only’ lead…? Might it be faulty?

I don’t know this. I have never used this kind of wire. You should have sold the kind of cable, the first end can be inserted into the phone, and the other end can be inserted into the usb (note that other usb cables can be inserted). Use this cable to connect the normal data cable of the trezor anyway, mine is easy to use.
Also, what is the version of your Google Chrome?

I’m using the latest version of Chrome that is currently in the play shore.

My lead goes straight from the trezor to the phone. I don’t see why two would be needed.

1 Like

I have never encountered your situation… I suggest you go to other posts @ community support

try different cables, ideally different phone, it could be HW issue, so open the ticket

Your photo shows Trezor One without firmware installed.

It is somewhat likely that it’s from an old batch where you cannot install firmware via WebUSB.

You will need to use a computer to perform the first-time setup. After that, your Trezor should work OK with a phone.

So I tried these different leads earlier. I paid extra when ordering for the mini c to mini c lead, which came seperately but in the same envelope. Now I tried the mini c to full size usb which came inside the box with the trezor itself. I’ve paired this with a OTG cable which I’ve previously used for usb memory sticks both on my phone and tablet so it works. The result, as you can see, is the same. Pretty frustrating because I specifically asked before purchase stating that I don’t have access to a computer.

I’m going to have to go to a public computer, which here in Cambodia means a gaming cafe, with no access to usb. I’ll have to ask the staff to assist, if they’ll even do it. Hardly secure.

If I do this, will it be possible to just get the firmware without revealing the seed, but do that later when I am alone? Can I get the firmware without installing anything to the computer, as that is definitely blocked/not allowed.

The link to the support ticket leads to a page to search, no form to fill in/ticket to initiate. I can’t find any contact info at all for the company bar facebook, and my fb message is unanswered.