Can’t access Wallet after Firmware Update

I have this same issue after I did a firmware update and I tried all the recommended steps but the display does not light up when I plug the device in.

I contacted customer support and opened a ticket (Ticket ID: 75703) and I received an email saying it might take up to 20 days to address my issue. It has now been more than 20 days and I still did not receive any response.

1 Like

Hi @truchiranga

Sorry to hear you have been experiencing such difficulties. We will prioritize your issue, and come back to you as soon as possible.

Thank you for understanding.

Hi Trunchiranga,

I have same issue.

What’s your situation?
Did you solve ploblem?

I got a replacement device from Trezor. The process was bit of a hassle and it took some time, but eventually, they sent me a new one.

Good for you!! :slight_smile:

now I’m asking to support team.

Have a good day!


So I just got my Trezor One, connected it, it was working fine, downloaded the trezor suite, it started doing some update as soon as the suite opened and after the update, it displayed that I should disconnect and then reconnect the device without clicking any buttons, & so I did and then the display just turned off.

Tried different wires, laptops, mobiles, repeated the process over 20 times but the display just won’t turn on!

Tried installing Trezor bridge, and everything that was possible, but the device has just isn’t working. Can someone please help?

Ticket: 89912

Hi @Bruh7

Thanks for submitting a ticket. We will come back to you ASAP.

1 Like

Please do do it as soon as possible, because 20 days to reply to a ticket is toooooooooooooo long and almost unacceptable!

Please, check your inbox for further details.

Hi Pavel,

Thanks a lot for your quick response, email with all the necessary details sent.

Warm regards

Dear Proval,

Could you check my Ticket?

I’m still waiting for Support team’s response.

Ticket ID: 89270

@pavel I’m experiencing the same issue. It was working fine until I got to “reconnect the device” stage of the firmware update, and then it never powered back on. I’ve tried different cables, computers, and everything.

Ticket ID: 93972

Hi @inaleticswetrust

Thanks for reaching out and for submitting a ticket. Please, check your inbox and come back to us.