Brand new Trezor | stop working after Firmware update

i got my trezor today, connected, download app installed the firmware, the says to disconnect and reconnect, after reconnected stop working, display does not lit. try two pcs, different USB etc

opened a case but way 20 days for a response its too long for a new item, please help

case no 93360

Hello Thorco,

Similar to you I updated the firmware about a week ago and the balances in my hard wallet disappeared. I can see the crypto at their addresses but nothing on my Model T. This is incredibly worrying and frustrating and being told that maybe they’ll get back to us in 20 days…, completely unacceptable.

worst support ever, brand new stopped working and we need to wait 20-30 days for a reply. and looks like this is very common issue.

Hi @thorco

Sorry for such inconvenience. Please check your inbox for further details about the issue.

Hi @zousan

Please, check this post first:

And come back to us if needed.


I followed the instructions on the online user manual for doing that and it did not work. I did it a couple of times and I still can’t see my hidden wallets. I can see the crypto at the addresses they are at using a different platform but the Model T doesn’t show my hidden wallets, even after doing the recovery process.

Thanks for letting us know. Please, follow the instructions sent by email, and come back to us how did it go.

Please, do not create multiple posts with the same issue. As my colleague has already replied to you, we will continue with troubleshooting your issue via email. Thanks for understanding and for your cooperation.

hey Pavel! i opened this topic, where is my support??

i have not received any email from you guys yet.

Please, check your inbox, including spam folder.
Anyway, I just sent you PM; with the email message enclosed.

thanks! just shared the video.

please check it and advice



I followed the instructions in the email and the instructions were the exact thing I did before as written on the online user manual. The issue is not solved. I repeated the procedure multiple times and I get the same result. I do not see my wallets with my crypto. I emailed Michal via Trezor Support and I included screen shots so he/you can see what I am seeing. I look forward to the next email with the next steps to take.

Thank you.

@zousan Check your inbox for updates. @MichalZ just replied.

Please, be patient and follow the instructions sent by email. When troubleshooting, it’s necessary to make sure, every steps were followed properly.

The most efficient assistance you get by using only one channel for communication as it’s much easier to keep on track and follow the whole troubleshooting process.

Therefore, please communicate your issue with MichalZ by email.

Thanks for understanding and for your cooperation in advance.


I replied to the instruction a week ago and i havent hear from anyone.

I sent the video as well.

Could someone help? I really need a working trevor

Hi @thorco

Thanks for sending the video. Please, check your inbox for updates.

I have the same issue - My newly purchased trezor one has been bricked during the initial firmware update. Ticket 94608
More than a week passed but no reply.

Can someone help please.


i replied with the informaton required 4 days ago and still waiting for any update

Hi having the same problem as well. newly bought device, after update no display on lit nor any connection to the pc. cant event restore factory settings. please advice ticket ID: 95849

Hi guys, please check inboxes for updates.