Unable to withdraw solana spl token even after updating to latest suite

I am having this issue for over a week now where I can’t withdraw SPL tokens to a hotwallet. The new version of suite v24.3.3 saying the issue is fixed and the following were added

*** Added priority fees for SOL**
*** Added popup in SOL send form waiting for transaction confirmation**

But everytime I try to withdraw I have to wait 1min and I get this error

Why say that I coin is supported on Trezor when you can’t even do the basic task to withdrawing it? I have tried 2 differet trezors with 2 different computer but still the same issue. And please don’t say use a third party wallet to perform this task as that just defeats the purpose of hardware wallet and security.

Can some please help with this as I really need to withdraw these tokens it’s costing me money now?



Trezor is completely broken. Several of us also have the wrong wallet addresses showing up on the trezor device, and their support team is claiming that’s expected and safe. Absolute garbage.

1 Like

Yeah I saw that wrong address thing and Trezor saying it’s expected which is so bad when they kept saying always make sure address on the device matches the actual address.

This is such a big issue like people can’t withdraw any SOL tokens not sure why this is not getting priority

Is there any further update on this?