Unable to sign ETHW transaction

I’m trying to send some ETHW from Trezor with Metamask and the transaction fails with “Forbidden key path” error. I tried fiddling with different browsers (Brave and Chrome), I’ve set the “safety checks” option to “Prompt” in Trezor Suite (which does allow me to interact with the device as opposed to silently doing nothing), all to no avail. I’m using model T with the latest firmware version 2.6.0. How can this be resoved?

Sorry, that’s me being lazy — I was trying to “Retry” the failed transaction in Metamask which resulted in device prompts, but no luck. When I started a brand new transaction it worked smoothly with the safety checks option turned on as above. Leaving this here for anyone who stumbles upon similar problem.

Also, keep in mind that the safety checks will automatically reset back to “Strict” after the device is replugged.

1 Like