Unable to send SOL tokens out, from Trezor Model T

I am getting this error when sending out Solana SPL tokens. I am able to receive Solana SOL tokens into Trezor though

“Transaction signing error: failed to send transaction: Transaction simulation failed: Blockhash not found”

  1. Installed latest version of Trezor Suite - v24.3.3
  2. Uninstalled, re-installed Trezor Suite
  3. Tried sending multiple times
  4. Changed from Default to Custom Solana backend in gear configuration

What am I missing?


You are not missing anything Trezor suite even after the update still has this issue. I have tried 2 Trezors with 2 different computers but still getting similar issue.

I have just opened a related topic as well this is so frustrating wasted entire weekend on this and I am losing money by not being able to send token to sell.

I get this issue first

and if I try again immediately after then I believe I am getting the issue you getting


Same error here when trying to send SOL USDT tokens.This is awful.

Transaction signing error: failed to send transaction: Transaction simulation failed: Blockhash not found

1 Like

I can’t send from nufi either

I also got this error combined with having the wrong addresses I’m sending to/from appear on my trezor device that don’t match what’s on my PC screen. Trezor support claiming apparently it’s “expected and safe” for the address that appears on the hardware wallet to NOT MATCH the pc screen.

Can’t put links in these posts, but if you search for “wrong recipient address sending sol model t” you can find that issue here on the forums.

This is ridiculous, what a piece of trash hardware wallet that has these kind of bugs. And a support team that’s completely indifferent.

Error from Nufi:

Please try again.

If the error persists, please contact our support & provide the error displayed below.

“Transaction was not confirmed in 90.00 seconds. It is unknown if it succeeded or failed. Check signature using the Solana Explorer or CLI tools.”

If I retry:
Please try again.
If the error persists, please contact our support & provide the error displayed below.
“failed to send transaction: Transaction simulation failed: Blockhash not found”

1 Like

FWIW when I tried, I also received the blockhash error most times. Eventually though after 4-5 tries my transaction was successful (albeit still showing the wrong to/from addresses).

I get the same error as @carl794 above: TransactionExpiredBlockheightExceededError. When I try to trade on the Suite itself, everything just says ‘No provider’ for SOL. Does that mean SOL on our Trezor wallet is completely frozen? Has anyone ever sent SOL out from Trezor? Has anyone opened a ticket about this?

I was finally able to send. What worked for me was using the web trezor suite and not the desktop app. I suspect this is an issue around trezor’s implementation of solana priority fees and a busy network today. Did they implement something in the web suite that hasn’t made it to the mac desktop app yet? Or maybe the network just cleared up… who knows?

1 Like

Worked on web app for me too! Thanks!

That’s frustrating that their web app works better than the desktop app though…

I can’t use the web version as I have a hidden wallet with passphrase and apparently web version doesn’t recognise that and always give me an empty wallet. The same passphrase when entered on desktop works fine.

Seriously thinking of moving to a different HW wallet once I get my funds out.

So basically Nufi isn’t working for anyone as well?

you probably didn’t enable your coins.

the web version and the desktop one are basically identical in all regards. it’s not possible that the same passphrase would work in one and fail in the other.

1 Like

that does sound like a fair point I will try to enable coins and report back.

Can you please address the main issue of withdrawing SOL from Trezor?


we’re actively working on it. the current situation sucks.

(between us, the Solana blockchain tech is not at all helping things. but you as users should not need to care about that)

I was able to see my wallet in web version by enabling coins as you suggested so thanks for that.

Although I am getting the same error on web version as well and I can’t withdraw my coins. I have been trying for week now and it’s so painful when you can’t sell your coins when prices are up and now you losing money cuz the market is going down.

I understand your point on SOL blockchain tech but if that was the case you should have not mentioned that it’s supported. Let’s be honest if you can’t do a simple task of withdrawing your coin then to me its not really supported properly yet

Also the new version of the suite mentioned that this issue was fixed, I am developer myself did this not go through any internal testing before shipping it?

I appreciate your replies is there any ETA on when this issue will be resolved?

1 Like

unfortunately web didn’t work me :frowning:

Can you at least put something out on the official site saying there is an issue with SOL withdrawals so don’t deposit SOL/SPL tokens?

That way other people won’t be stuck with funds like us

That’s kind of fair. In our defence, it had worked before it broke :woman_shrugging: The current network congestion is doing a number on Solana.

That’s a different issue, namely, priority fees. In the previous release it was not possible to specify a high enough fee. That works fine now, but other problems cropped up instead.

FWIW, I’m told that you can resolve the sending problem by just closing out the transaction and trying again. The first error you’re getting is about the transaction data “timing out” essentially. This would normally not happen unless you stare at your Trezor for several minutes before confirming – but, well, here we are.
The second problem is likely caused by trying to replay the same transaction data. If you exit the send screen and start over, it should go away.
Again, normally this should not happen and it should let you retry straight away. As a workaround, to try again, you should be able to exit the “send transaction” flow and making a “new” transaction.

No ETA. But it is being actively investigated.

funnily enough, all this might not even be our fault: apparently 75 % of txes on Solana are failing these days for everyone

I can still send SOL out of phantom without any issues!

Also, I have been trying for 2 weeks trying to send it out of Trezor no luck. My friends are using Ledge and no issue there as well.

But I am not here to do the blame game just please fix it for us so i can get the SOL out.

Also please put something on offical channels saying SOl withdrawls are affected don’t deposit cuz don’t want other people to suffer this way too