Trying to connect Trezor to Metamask - PIN not working

After clicking Export on the “Export public key of Ethereum account #1 page”, I get asked for the PIN. No matter what I enter it doesn’t work - it just asks to re enter the PIN.
I’m 100% sure I’m entering the correct one because it works on Trezor Suite.

I’ve also tried the commonly suggested fixes that are suggested:
Updated everything, tried private window, tried chrome, cleared cache, made sure trezord.exe is running.

Is there anything else I can try?
The only idea on why it isn’t working is that my PIN is longer than 9 numbers, and it doesn’t allow strings that long. Is that maybe the case?

Hi @trezorqwe,

thanks for pointing out this issue!
This issue is only related to the Trezor Model One.

I can confirm that the reason why your PIN is not recognized in MetaMask is connected to the Trezor Connect interface that MetaMask use. PIN longer then 9 digits is not recognized as valid in Trezor Connect. The issue can be tracked here: Allow PIN longer than 9 digits in Connect v9 · Issue #7667 · trezor/trezor-suite · GitHub

Our developers are currently working on the issue. In the meantime, there are two solutions:

  1. You can change your PIN (max. 9 digits). It can be done in Trezor Suite, more information here:

  2. You can unlock your Trezor Model One in Trezor Suite, close it and continue in MetaMask. The Trezor will stay unlocked for 10 minutes by default. This time can be prolonged in Settings (“Device” tab → “Customization” section → “Auto-lock time”)


Thought it was a bit suspicious that I got no visual feedback after the 9th character haha.
Thank you for the answer!