Tried using 2 different Trezors on one PC

I tried opening 2 different wallets on same PC (One and model T) and now it seems I cant get into either . The software seems really confused. It accepts my pin, but them doesnt load coins. Should I just wipe the Trezor? I tried resetting the Trezor suite, but that didnt do anything

try a different PC. Is the PC in question windows by any chance.
I don’t have much faith or trust in windows PCs to be honest.
I think that once a trezor is setup and running, unless you update the firmware or wipe it, very little/nothing changes on the Trezors. I’d go for this being a PC problem as my first guess.
Or bad cable or USB socket etc.
Also laptops running on batteries often output very little power to USB ports, which can be an issue.

yes, PC’s. I tried accessing one of the trezors on another PC and still get error messages. Not sure how to proceed

It says Trezor bridge not running!

sounds like the bridge has not been installed then, or needs removing and reinstalling.
What OS?

Dear @biziz42,

If you see an error that the Trezor Bridge is not running, you should download a install the bridge from our website:

You can also try the desktop app:

Is the Trezor device recognized by your computer?