Trezorctl problem, (Ubuntu 22.04)

good evening, i just got my trezor T, got it setup and tried to install trezorctl but when i got to lunch it i get the below error, it looks like it is while trying to load trezorctl so i feel like i am missing a part of the install, (it was installed with sudo apt install trezor in ubuntu 22.04) trezor suite works. and ideas what i need to do to fix it?

Traceback (most recent call last):
  File "/usr/bin/trezorctl", line 33, in <module>
    sys.exit(load_entry_point('trezor==0.12.4', 'console_scripts', 'trezorctl')())
  File "/usr/bin/trezorctl", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.11/importlib/metadata/", line 202, in load
    module = import_module('module'))
  File "/usr/lib/python3.11/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1204, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1176, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1147, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 690, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 940, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/trezorlib/cli/", line 171, in <module>
AttributeError: 'TrezorctlGroup' object has no attribute 'resultcallback'. Did you mean: 'result_callback'?

Your trezorctl version is out of date.

I’m guessing you got it via the operating system package python3-trezor? If yes, please open an issue on Ubuntu’s issue tracker, they should be able to fix it.

For a workaround, you can install pipx and use it to install the trezor package like so:

pipx install trezor
1 Like

that fixed it, thank you vary much. ill see what i can do to open an issue