Trezor T + Passphrase + Bridge

I use the trezor T on the RSK network through the Nifty wallet. When it connects to the bridge, it won’t let you write your passphase to the device, I think it’s a security problem.

You only have the option of writing your passphrase on the PC

That is a bug of Nifty Wallet. It should show a button “enter on Trezor”.

You can alternately use the trezorctl tool to enforce always entering on Trezor:
trezorctl set passphrase enabled --force-on-device

1 Like

Learn more about trezorctl tool

I did that but first when I click on Export button the page is closed and device is not expecting any passphrase. I guess I should set it back to disabled to make it work at least?
but it’s still forcing me to enter the passphrase