Trezor Safe 3 incompatible with Monero?

The official documentation claims that Safe three is compatible with Monero:

I cannot see it in the list of supported hardware devices in the Monero GUI. The only Trezor device that’s supported is Model T.

The Exodus wallet also seems only to support Model T:


I only purchased Safe 3 to use with Monero. How do I do that? Can I receive a refund, possibly an exchange for Model T?

I use my safe 3 with monero GUI all the time.

Just select model T and it’ll accept it, done.

It’s not working for me. Produces an error. What OS do you use?

Linux mint (ubuntu).
Been doing it for sometime, no problems, are you using the latest version monero gui.

Does the safe 3 work OK in trezor suite?

Yes, the Safe 3 works well in Trezor Suite. I set it up and all. I’m using Void Linux. I’ll poke around more and see if I can get the Monero GUI working with it.

Yes just tested, works fine for me.
Have you tried the feather wallet appimage?
maybe have better luck with that?
I take it the trezor bridge and udev rules are all good?
I would have thought they would be cos it works with trezor suite…

edit: what is the error say?

also on the latest version of monero gui, ‘safe 3’ is actually listed on the drop down.
my version is , what’s yours?

Yes, I had an older version of the Monero wallet. After upgrading, I can now see Safe 3. However, I am still not able to connect. I get this error:

2024-03-21 02:36:25.580     7f27cb3fd6c0        ERROR   device.trezor   src/device_trezor/device_trezor.cpp:176 Get public address exception: Call method failed
2024-03-21 02:36:25.580     7f27cb3fd6c0        ERROR   wallet.wallet2  src/wallet/wallet2.cpp:5053     !hwdev.get_public_address(device_account_public_address). THROW EXCEPTION: error::wallet_internal_error
2024-03-21 02:36:25.582     7f27cb3fd6c0        ERROR   WalletAPI       src/wallet/api/wallet.cpp:718   Error opening wallet: Cannot get a device address
2024-03-21 02:36:25.586     7f27cc934840        ERROR   frontend        src/wallet/api/wallet.cpp:415   Error opening wallet with password:  Cannot
get a device address

perhaps this is something to do with your OS…
permissions related maybe?

Sorry can’t be of much further help.
Edit: I suspect you’d get the same result with a model T

1 Like