Trezor Hardware account linked to Metamask not sending funds to other address/wallet

this is the same issue, It doesn’t ask for any password.
I leave the passphrase blank too.

One solution was to downgrade MM but I haven’t done that yet since I don’t want to loose the account and possibly loose the funds until I get a better solution.

@deadxnurse,

Ok, but if you are in contact with Community Support through your Ticket then you’re in good hands. Talk to them on email and good luck! :+1:

I just reset my MM and now I am unable to retrieve that Trezor linked hardware account with MM.
When I choose ‘connect hardware wallet’ I can’t find the previous address of that particular one with ETH in it.

yes! PassPharase! for some reason I forgot I had another PassPhrase and once I tried a couple of them I opened the same address I used to link it to Metamask. (that’s the tricky thing about Trezor! every time you plug in your Trezor and insert your PassPharse it will open like normal even if you put in a different PassPhrase and you don’t release that is not the same address you open) but I don’t know what happens when you reset your Trezor, maybe you lose those addresses and get new ones. hopefully, you could recover yours mate!

@deadxnurse,

Please communicate this through email on your Ticket.

Hello any updates here? I have also the same problem as you. The only difference is I did not transfer fund to Trezor suite. My ETH is stuck up in Metamask for 3 days now. I contacted Trezor and gave me a ticket. Hoping for their response. I do not know how I could get my funds stuck there

thanks

I also have this same issue. I think I just realized why. I setup my trezor, connected it to metamask, then in MM clicked connect hardware wallet. Then it will ask you to pick a Wallet address, in which you are supposed to pick the same address that is listed in Trezor suite when you set up your trezor. But I didnt, i must have selected a different wallet address on the metamask list. So im trying to send funds out of my trezor using mm but its just stuck loading like the others here. I also didnt select a pass phrase or hidden wallet on the trezor suite. But I might have selected one during the metamask connect hardware wallet set up. What can I do to fix this?

Dude I have the same issue. and followed the same process, any solutions yet? I am trying to buy NFTs on opensea but when I sign the transaction it just goes to opensea loading page and never loads.

I also have the same problem and as I can see Trezor didn’t solved anyones problem yet?
I also sent them an emai, but didn’t receive a ticket number, is there a specific page where I can submit my issue and get a ticket?

1 Like

I got the same issue, Metamask accouny connected to trezor. When I send the money out of the wallet the browser freezes.

I tried with MEW I get the same result.
I hope someone can help us.

I sent a ticket 126299

i have this exact ptoblem…did you find the solution?

in the end…did you got your funds?

Same thing happened to me in my RONIN wallet. Now I can’t use or get the funds stuck in trezor 1 address. :frowning: I lost hope trying… nobody seems to have a solution

I have the same problems too.

One thing i realised, I reinstall Metamask and reinstall it again. When I try to add the hardware wallet Metamask, I noticed that the usual address is no longer in the list of Trezor address…

I sent a ticket too 129701. Hopefully someone reply this issue

Funds lost in the Metamask ‘Connect Hardware Wallet’ feature!
Hi all, looks like I am the next victim of the rubbish integration between our pioneering Web 3 leaders Trezor and Metamask. Read all the thread and here is my story. Trezor setup fine, and it appears during the initial setup it comes with a default BTC wallet. So in hindsight, I should have also added an Ethereum wallet to the Trezor suite, which I didn’t. from what I recall, I went straight on to MM and selected the ‘Connect Hardware Wallet’ option in metamask and when that happens it appears to communicate with the plugged in Trezor and presents a series of random accounts (ETH addresses), something like the following:

No idea how these get generated and is it done by the Trezor device? Anyway, I selected one of these accounts, and appeared perfectly fine as a new account on my metamask, and all good on Etherscan. All good so far! Back into metamask and sent a bunch of ETHs across to the new account and (about two weeks ago). Anyway, yesterday, wanted to send ETH back out of my new ‘hardware trezor protected’ account and got the freezing, fails etc…Hence research brought me to this forum.

Anyway, the first question I have is, who generates these random accounts that I inadvertently selected and my ETH is now caught in never-never land - MM or Trezor? And can I assume, that the keys for this account are held somewhere on one of the systems?

To get this ongoing issue solved, we probably need a second or third-level engineer who understands the firmware etc… to help with this one? I do know Ledger offers a service that involves shipping the USB key back to them to retrieve wallets et…

Oh, I did log a ticket (Ticket ID: 133479) and hope that these ‘Web 3.0’ organizations become more like traditional Web 2 and indeed Web 1 companies and help the many people in this forum who are in this weird situation over a simple oversight.

Thanks,
Gerard

hi @punkcowsnft

No there is no reason for that since Trezor Suite is only an interface (the app actually has some more features such as setting up and controlling the device itself however since it is not important/related to this case so we can establish that it serves mainly as an interface).

So adding the Ethereum account to Trezor Suite prior connecting your wallet to MetaMask would not affect the situation a bit.

That’s not true since the set of the addresses you are offered to connect to after you export your public keys and enter passphrase (if used) is not random but derived from your private key.

This is actually related to your next question:

The simple answer would be yes, these are done by Trezor device because every address is derived from your private key (backed up by the recovery seed) that is always kept securely offline on your Trezor device and never shown, even to you.

The derivation process is as follow:

Recovery seed → Account private key → Private key → Public key → Address

Users can create as many addresses as they want without any costs. Please note that there is a soft limit of 1M addresses (Trezor firmware limitation) however if you disable safety-checks you could carry on further (which personally I see no point in doing so). Also I don’t believe that MetaMask would even allow you to connect address with such a high order.

Now regarding the derivation process itself:

A mnemonic phrase (recovery seed) generates addresses by taking the phrase and combining it with a piece of information called a derivation path. Together, they create any number of accounts, using complex math aka cryptography.

Speaking about Ethereum, the addresses ( which are basically unique identifiers) are derived from public keys or contracts using the Keccak-256 one-way hash function.

For more information please see following links:

If you want to broaden your horizons even more I recommend reaching for the following book:
Mastering Ethereum by Andreas M. Antonopoulos, Gavin Wood

That has been basically answered since it was already stated that all addresses are derived from unique private key that is created and stored offline on Trezor device

There are basically two scenarios why is this happening.

A) there are some connectivity issues thus your Trezor can’t communicate properly with your MetaMask (browser extension). In such case try following:

  • Use supported browsers only. Either Chrome or Firefox (try both and try using Incognito/privacy mode as well).
  • Not only using a VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.
  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.

B)You are not using appropriate private key to sign the transaction (the same that was used to create the address from which you are trying to spend now).

This happens most often when using passphrase feature.
When the feature is activated (it is activated by default), the user is prompted to enter the passphrase which is then combined with the recovery seed on the device, and a new wallet is generated.

So extremely simplified: you can imagine passphrase as an extra word of your recovery seed, thus when being used (and because of the derivation process mentioned above) new wallets account and addresses are being derived.

And when it comes to signing the transaction:
MetaMask (as well as any other wallet) would be preventing you from spending your funds when the (appropriate) private key is missing.

These private keys for signing transactions are derived from the combination of seed stored on Trezor device and passphrase (if enabled and used). Hence, if different seed and/or a different passphrase is used then the private key differs and cannot be used.

In such case, previously generated wallets/accounts in third-party apps would become watch only wallets without the possibility spending the funds.

You can always conveniently check if you are using the right combination of seed and passphrase by looking up for the address that you are trying to to spend from using following tool: https://findeth.io/
If you won’t be able to find the address using the same seed (device) and passphrase (as you do when you try to sign the tx using MetaMask) then one of the inputs (or both) differs.

Also please see following video:

2 Likes

Looks like there are many of us in the ‘watch only wallets’. Trezor needs to do something about this. It’s not even clear how this can happen in this day and age! Hoping to get some feedback on ticket 133479.

I know for certain I created a standard wallet. Why is it watch only? And how do I fix it

that’s how Metamask is designed, it’s not an issue of Trezor. But, yes it can be confusing.