SPL transactions not showing up and going through on Trezor Safe 3

Was trying to send SPL tokens from my Trezor Safe 3 to my phantom wallet on trezor suite.

Signed the transaction and a popup box on the right top corner says transaction signed and going through. Pop up box disappears and coins are not sent.

The transaction does not show up on transaction list either. no gas fees are consumed…
I tried this 5-6x 12 hours ago and same thing happened. Just tried it again 2 hours ago and same thing.

3 days ago I was able to send SPL tokens to a phantom wallet with no issue.

Also of note is I have 4 unknown transactions (gas fees?) since my last successful SPL token transfer 3 days ago

Anyone else running into this problem?

Yes I’ve had problems as well.
I solved it by using the nufi wallet with my trezor.
google it, just ensure your on the correct site as always.

Just posted the same issue moments ago and saw you’re having this issue.
Activity shows it was sent but token didn’t send.

Same issue here. Cannot send out SPL tokens. It takes me through the process and act like everything works fine, but the tokens aren’t being sent out. Can someone assist?

Yes, use nufi wallet and it will work

1 Like