Runtime error on PIN setup. Device stucked

Yesterday my trezor safe 3 arrived, I proceed to set up my new wallet and the seed 12 words . Everything ok so far. It was latenight then I desconnected the trezor and went to sleep,. Today i proceed to set up the PIN number, reconnected the trezor and set up the pin number at the device. at the last confirmation i get the this info in the trezor screen : Internal error - Runtime error -
now the device is stucked with this message on the display. Someone Help me please.

thanks in advance

please show the exact text of the error, or post a photo of the screen

here you have ! Thanks

Thanks! this is an interesting one.
However, factory resetting the device should help.

Hold down the left button before you plug in the USB cable. This will take you to a bootloader menu, where you can navigate to a Factory Reset option. Then set up the Trezor again.

Let us know if this helped, or if you manage to hit the same error again.

1 Like

Thanks for your help matejcik !
The factory reset worked and the issue solved.
I guess that the problem happened somehow when i was trying to set up the PIN with the tor enable and poor internet connection,

1 Like