Restoring Trazor Model One 24-word on Trazor Safe 3 -- fails

Long time user of Trazor Model One. Recently acquired the Trezor Safe 3. When using Trezor Suite (desktop) to restore my 24-word seed from the Model One (a validated seed) to the Safe 3, at around the 18th word (sometimes 20th), Trezor Suite display a “Recovery Failed” message. I have tried this a number of times with the same result. As mentioned, my 24-word seed is valid on the Model 1.

The strange thing is that on about the fifth try (thinking I was making a mistake), I continued to add the remaining words on the Safe 3. To my amazement, they were accepted. I cancelled the Trezor Suite message and it all works.

My concern is about Security, given the problems described above. Is there a flaw in the firmware of Suite?

Thanks in advance for any insights.

Hi @Roberdeni,

There is no need to worry about the security. The issue with the recovery process has been spotted in some versions of Trezor Suite version 24.3.3 (in combination with specific OS). Anyway, it has already been fixed in the latest version 24.3.4 which can be downloaded at or accessed at

Please, try again in the latest version of Trezor Suite, everything should work as expected.

The security is not endangered anyhow.