Problem pc moving slow

Hello i have an issue, i already install my trezor suite, also configured my trezor, do all the things, but my problem is when i connect my trezor and open trezor suite app my pc start to work very slow, the mouse start to frozen and its pretty annoying, why this is happening, i already have sent some things to my trezor and everything its working pretty normal but that frozen thing its so annoying, its normal?

2 Likes

Hi @Potato

I would suggest you checking your CPU, and have a look at other processes running in the task manager. Never heard of an issue that Suite would significantly slowing down the PC performance.

Anyway, consider re-installing Trezor Suite and make sure you have been using the latest FW. Also, if you are experiencing issues with your Trezor Suite desktop app, consider using Trezor Suite web app instead, available from https://suite.trezor.io/web/ or our stable Trezor Wallet https://wallet.trezor.io/#/

1 Like

It’s the app i tried the web version and my pc its working normally, it’s pretty weird, i already re-installed trezor suite but the problem continues, well i’ll use web app instead of desktop app

Does the same thing happen if you close your browser window(s) when using Suite? What other apps are you using? Things like Slack, Discord, Signal desktop, to name a bunch of the popular ones that eat a lot of RAM.

This sounds like your PC does not have enough RAM for Suite and other things to run at the same time.

Same thing happened to me I Already reinstaled Trezor Suite but not getting anything its still Slow, I’m going to try using trezor website App istead.

In my PC I have 16gb Ram 87gb available on my SD Hard Drive and GTX 1050 Ti. Unfurtunetly the problem its looks like its from the Suite App. since the resources available are enough I dont have any software installed in my PC no more than Firefox and Chrome.

I found this problem but resolved.
My mouse cannot work while plug Trezor and Trazor Suit slowly.

I used my laptop with Trezor One normally for a month. I don’t have any problem before.
But last weekend my mouse cannot move after plug Trezor around 5-10 second and Trazor Suit was slow down from previously.

First i thought my mouse or usb port is broken.
I already test with other mouse but still facing this problem. And i try to use my mouse with other PC but it work as normally.

Today I re-install Trezor Suit but still facing this problem.
Then I found this topic on google. I try to use Trezor on web and Trezor web direct me to install Trazor Bridge again.

After install Trezor Bridge I don’t found this problem anymore. My mouse can work while plug Trezor and Trazor suit not slow.

First day with Trezor and same problem :confused:

Windows 10, 16GB RAM

Fck, mouse/sound still lagging after uninstall and pc restart.
OMG

This is very bad.

Well a hint.
If I unplug mouse and plug it back then lagging is gone.

WTF guys?

Mouse Logitech G502

Mám ten samý problém. Nemyslím si, že je to tím, že bych měl nedostatečné CPU nebo paměť. Naopak mám 16GB RAM a i5 procesor novější řady.
Tenhle problém se začal dít od nové verze. Aplikace se spustí a začne fungovat, ale přetažení myší udělá zamrznutí na 3s pak se zase dá s myší pohnout. Klik na cokoliv je taky opět na 3s a musím klikat několikrát. Po vypnutí Trezor Suit se počítač zase rozjede.

Takže to je zřejmě problém v aplikaci a ne na PC.

Po nainstalování bridge do prohlížeče je problém vyřešen. Hmmm takže aby vám suit fungoval, musíte mít nainstalovaný i bridge. Hezké.

Is the whole PC laggy or is it just the mouse?

Does the problem appear when Trezor Suite is running but Trezor device is unplugged?

The whole problem appears as soon as the Tresor Suit application starts. And because of that, the whole computer is stuck. Not just the application itself. The problem disappears as soon as the Tresor Suit can be switched off.

Or the whole problem now is not after installing the plugin in the Tresor Bridge browser. So the problem also stopped appearing.

I would add that the problem was even though I had the device disconnected from the computer.

1 Like

Honestly it just sounds like your pc either has issues in the registry or its just needs a cleaning, i.e reformatting your pc to the newest build of windows. reinstall drivers problem solved

I disagree with your statement.

  1. I am not the only one describing the same problem.
  2. Lots of users above said they have the problem even with freshly installed windows. (Mine were installed 3 months ago and have the latest updates).
  3. The problem was fixed once Bridge for the browser was installed. (So I guess that Brdige is the magic tool that can fix registry problems)
  4. The problem only appears when the program is started. Once the program is not running the other applications work fine and users have not otherwise noticed this behavior.

From all these indications it is clear that the problem is not on the users side, but on the SW itself.