Passphrase is no longer working, empty wallet

Exact same passphrase is no longer working to access the same hidden wallet one year later. What happened?

A year ago I got a Trezor Model T to store some ETH, ERC-20 tokens, and some NFTs (all on the Ethereum blockchain). I used the new passphrase feature and made several hidden wallets to store the assets using those passphrases. It all worked fine many, many times to access those hidden wallets with those passphrases both using Trezor Suite on my Mac and the MetaMask Trezor plugin.

Now, after a year of not touching my hardware wallet or anything related to crypto, I am trying to access my assets in those hidden wallets, but now when I use those exact same passphrases (and I know I’m using the same ones since I have them written down on a piece of paper) the Trezor Suite software (and MetaMask) are opening up empty wallets with different addresses that have no transaction history at all. I have no idea what happened. It’s almost like the Trezor Suite software was updated during that time and now uses a different algorithm to calculate the hidden wallet address and private key pair based on the text of the passphrase. I know that sounds crazy, but I don’t know what else could have happened since nothing else has changed.

I did find one other case of someone using the same passphrases on Trezor Suite on different computers and having different, empty hidden wallets come up. See the link below. They didn’t say what resolved the problem.

I even tried upgrading the firmware on my Trezor Model T since a new version had come out to see if that would help, but the passphrases were still producing the same empty wallets with no transaction history as before.

Any help with this would be greatly appreciated. As you can imagine, this is a scary and bewildering situation. Thank you so much!

I did try using my Trezor with MEW and with one of my known passphrases. MEW brought up the same empty hidden wallet that Trezor Suite had accessed. Obviously, this would be expected normally but I just wanted to see if this might help me access the hidden wallet that used to always be accessed with that particular passphrase. No luck :confused:

Maybe I should try to install the old version of Trezor Suite that I was using last year? And perhaps also install old firmware on my Trezor? I’m just trying to recreate the conditions that allowed me to use these passphrases with my old hidden wallets successfully so many times last year. I never once had a problem last year with these passphrases.

Another detail that might be helpful to know is that last year all four of these hidden wallets that were accessed using these four different passphrases had at least a little ETH in them. Now, all four hidden wallets that come up using the exact same four passphrases are empty wallets with no transaction history. I can see the old wallets on the blockchain and all of the assets are still there so nothing was stolen or hacked as far as I know. All that has happened is a change in which hidden wallets come up with the same four passphrases. It’s very mysterious to me and I wouldn’t blame you for thinking I had made a typo. I was concerned too but the fact that all four came up empty and never used this time versus all four having some value in them before made me realize something was definitely wrong on the software side somehow and it wasn’t just me messing up the passphrase with one of my hidden wallets. Every single one is affected.

they come up empty because they are different wallets, not the same, because you are using wrong passphrase.

there is nothing wrong, that is exactly what happens when you use different passphrase.

Trezor uses BIP39 standard for seed and passphrase, nothing has changed

If you have not used it for a year I would say there is a big chance for error, have you used a different computer, maybe different keyboard layout and now entering wrong character?

If it’s not a typo in the passphrase, it might be that there is now a different seed on the devices. (a wipe & restore gone wrong perhaps?)
You can check your backup to make sure.

1 Like

Thank you for very much for taking the time to reply! I appreciate your detailed help.

I certainly realize that what I am describing sounds impossible, but all I can tell you are the facts:

  • I used these four passphrases probably hundreds of times last year without having trouble reaching the same four hidden wallets. I never had a problem. I received ETH, ERC-20 tokens, and NFTs in each wallet and was also able to send these items out from each wallet at different times.

  • These four wallets still exist on the blockchain and still contain all my assets. Nothing has been stolen or hacked as far as I can tell. No transactions have occurred on these wallets since last year when I was using them.

  • These four passphrases were written on a piece of paper and I always looked at that paper before typing in my passphrases last year since I wanted to make sure I typed it in exactly right. I also always looked at the passphrase displayed on my Trezor Model T before confirming it to make sure it matched what was written on the paper.

  • There are lowercase and uppercase letters with spaces in-between in all four passphrases but there are no numbers or special characters in any of the four passphrases

  • Now, a year later, I am using the exact same piece of paper that I used last year which was kept in a safe with my passphrases written on it. I am typing in those same four passphrases just as I did before last year so many times. And every time I am confirming that the passphrase shown on the Model T matches what I have written on the paper. The paper has not changed and the passphrases have not changed.

  • Now, when I use these same four passphrases, I am always getting a brand new, empty hidden wallet with no transaction history and no contents. I tried using Trezor Suite on my old computer (Intel Mac) that I was using last year, I tried using Trezor Suite on my new computer (M1 Mac), I tried using Trezor Suite web version in Chrome on my new computer, I tried using MetaMask with the Trezor connection feature, and I tried using the MEW online wallet while connected to my Trezor, and then I tried upgrading the firmware on my wallet to the latest version, and in every case these four passphrases were bringing up the exact same four brand new empty wallets with no transaction history and no contents.

  • Now, when I open my wallet using Trezor Suite in any of these ways it is showing my standard wallet (empty passphrase) with a little ETH in it (as expected) so I know that at least my standard wallet has not changed (which I believe means there’s no way my seed phrase could have changed or the device could have been wiped).

  • If only one or two of the four passphrases was bringing up an empty wallet, I would think there must be a typo or I was doing something wrong. But the fact that all four passphrases written on the exact same piece of paper that I used last year are not working now is so strange. The only way I could explain it was perhaps some funny bug in my wallet or a small software change that maybe only affected a tiny number of users.

  • I didn’t think it would matter but just in case it does I should say that I am using 5 Shamir Secret Sharing seed phrase lists with a necessary threshold of 3 lists generated as my backup for this wallet. I am not using just a standard 24 word list as my backup. I don’t know if this would change anything in how the software behaves when combining the seed phrase with the passphrase.

What I am asking now is, in light of the facts I presented above, assuming they are all true, what can I try for debugging? I know it sounds impossible, but please assume I am not lying or mistaken for the time being. Assume it is really true that I am using the same passphrases with the exact same hardware wallet that I used last year and now I am seeing different, new, empty wallets. Then what would you recommend? For example, should I try to reinstall the older version of Trezor Suite that I was using last year on my old computer? Should I try reverting the wallet to the old firmware that I was using last year successfully? Should I try wiping my hardware wallet and restoring it from my seed backup? Should I try purchasing a brand new Trezor Model T and restoring that new wallet using my seed phrase? I am really open to anything.

Thank you for your time and patience in answering my questions!

I did try using the “Check Backup” feature in Trezor Suite yesterday and it confirmed that my backup seed phrases (I typed in 3 of 5 of my SSS seed phrases) were correct.

I spent probably 8-10 hours yesterday and the day before trying everything I could and reading everything I could find online about how passphrases and hardware wallets work. So I know what I am describing sounds crazy and impossible, but this is truly what I am experiencing.

I would really appreciate recommendations from you and the other developers who might know what debugging I could try to solve this very strange and very unusual behavior.

Thank you so much!!

I was really hoping to hear back from someone regarding the questions in my reply above. I have tried everything I could think of. I even tried my known passphrase along with extra spaces after it (which would be invisible on the Trezor Model T screen). I tried every possibility from one space after my known passphrase up to the amount needed to make the total 50 characters according to the character limit for Trezor passphrases. Every single attempt brought up an empty wallet. Then I was wondering if it could have something to do with the derivation path? I saw the derivation path shown on my screen when viewing my wallet address was “m/44’/60’/0’/0/0”. But Trezor normally uses the derivation path of “m/44’/60’/0’/0” which is slightly different. So I thought maybe something related to a change in the derivation path could be why I’m getting different wallets with the same passphrase. Any help would be greatly appreciated. I can promise without any doubt that I am using the same wallet and the same passphrases because I have the original piece of paper. If I didn’t have that same paper that I used before I would doubt my memory, but I know with 100% certainty that I using the same passphrases that I used originally which produced different wallets. I’m trying everything I can possibly think of. I was going to try restoring my wallet using an extra Ledger device that I have but I realized it won’t work since Ledger doesn’t support the same 20 word seed phrase standard for SSS seed phrases. I would love to try a new Trezor Model T but I can’t afford to buy one just for trying something that likely won’t work. What would you recommend that I try next?

I should say that I still have the original papers with both my SSS 20-word seed phrases and with my four passphrases. So these have not changed with 100% certainty. And I know that I did not modify my passhphrases when typing them in. I always just used them exactly as they were written on this paper without modifying it at all like some people might do (e.g. add some extra characters or words to the end of each passphrase)

I would try downgrading the firmware as a first step. You can try several versions and see if anything changes.

If yes, I would be very curious about which versions work and which are broken.


It’s unlikely to be anything to do with Suite version, but of course that’s a cheap thing to try out. One theoretical possibility is if your passphrase is using any non-ASCII characters? There are several ways to represent, e.g., the letter “á”, and in theory something might have changed to use a different representation.

But as far as I recall, Shamir doesn’t even allow non-ASCII characters in the passphrase, so :woman_shrugging:

In any case you would see those characters on Trezor screen as �


It’s unlikely to do with the derivation path, seeing as Suite sees the standard account just fine. The derivation paths are (supposed to be) the same for standard and hidden wallets. It’s weird but possible that, e.g., all the funds in the hidden wallets would be in account #2 and if an account #1 is empty, Suite will not allow you to add the second account. In such case, you would need to try alternative software such as Metamask or MEW that allows you to select an address from a list, instead of always starting at zero.

That might be a good thing to try if you haven’t yet:

  1. install Metamask
  2. create a default hot wallet, do not worry about the seed because you will not be using it for anything
  3. once the initial setup is done, “Connect hardware wallet”, select your Trezor and input the passphrase
  4. a list of addresses will be shown, see if you recognize any of them. No need to go through the full list: unless you did exactly this in the past, it’s extremely unlikely that the right address would be anywhere outside the first ~5

If that doesn’t help, you can continue by using either MEW or MyCrypto. At least one of those allows you to select a derivation scheme, so maybe one of the non-default ones would be it. Again, unless you did this in the past, it’s super unlikely that the right address would be anywhere else than in the first couple spots.


The issue that you linked from github is 99% related to coins not being enabled in one or another Suite instance. If your ETH is disabled and you don’t have any Bitcoin in the hidden wallet, the wallet will come up as seemingly empty.


As a last, far-fetched idea: in August 2019, a firmware version 2.1.3 was available in early access for a couple days, then pulled back after discovering a bug in the Shamir implementation. Given that you say you got your Trezor last year, it’s next to impossible that this would be your problem. Also to be affected, you would have had to wipe and restore the Trezor at least once, and the standard wallet contents would also be changed.

1 Like

One more unlikely but super easy to test idea comes to mind:

Try opening the hidden wallets with only the first letter of the passphrase.

Thank you so much for your recommendations! I’m traveling this weekend so I can’t try them until next week but I will let you know how it goes.

@TwoLamps, I am having the exact same issue. I set-up a hidden wallet a few weeks ago and wrote down my passphrase at that time (same piece of paper); I transfered BTC from the standard wallet to the hidden wallet. I ran test transactions first to ensure the passphrase was working properly (and I was entering it correctly) to the hidden wallet several times in small amounts before transferring more, all good at that time.

I go to access my hidden wallet today - am prompted for the 2.5.3 firmware update. Take the update “successfully”. Open my hidden wallet and zero funds - same computer, no change in computer or passphrase. I’ve validated that the BTC is still in the wallet on the blockchain with the only inbound transaction being the original transfer, so I haven’t been hacked.

I’ve opened a ticket, not sure what to do next. All suggestions welcome (beyond ‘you’re entering your passphrase wrong’, I understand that for sure).

First question - how do I back-update my Trezor T to 2.5.2? Want to try that out…only thing that changed was taking this firmware update.

Second question - when I try to enter the passphrase on the Trezor T itself versus my computer (just to see if for some odd reason that’s driving it), it only allows lower case entry? There’s no option for uppercase?

swipe to the side to get different keyboards

This is happening to me too—I am unable to start a topic on it in this forum however…?

@Trezortendies you mean you’re inputing a passphrase and it gives you a wallet that is empty?

If so that is because you’re entering the passphrase,

Be aware that passphrase is case sensitive

https://trezor.io/support/a/passphrase-hidden-wallets-issues

If this isn’t the issue could you give more info on your situation?

I’ve used only 2 different potential passphrases for this wallet ever. I’ve kept note of them very well, and I’ve used this wallet within the last month successfully and in the past year before that. Yesterday it forced me to update the firmware and suite software. NOW this happens. I can confirm on BTCScan that the address I sent some satoshis in the past still have them sitting in there.

Well that’s a good sign in a sense that your wallet (seed and passphrase) has not been compromised, otherwise your funds would have most probably been already sent elsewhere.

Did you use it only for receiving or also for sending funds ?
I am asking since your wallet interface /session might have still been cached if you’d used remember feature - in that case such wallet would be watch-only.

Also, very important, since you have updated or perhaps even restarted Trezor Suite: what cryptocurrency are we talking about? Are you sure that you have all the desired cryptocurrencies and bitcoin account types (that you have previously used) enabled ?
Alternatively, have you tried using Trezor with different wallet interface ?

90% of this wallet is BTC, and it has never sent, only received (except perhaps when it was new)

and have you previously typed your passphrase every time you created some address in order to receive your funds?

Also, since we are talking about BTC, what account types did you use ? are they all enabled ?

1 Like