Not able to send BCH from Trezor T to exchange....invalid address?

Not able to send BCH from Trezor T to exchange…invalid address??
I did convert the address first…

Thank you forgi
It is the right address and I convertet it to CashAddr…
Everrything is green but when I push the send button…Transaction signing error: invalid Address
I can easly send internt in my TrezorT?

do you have correct BCH address? Make sure you are not using BTC.

100% sure…its kind of weird

open a ticket please and send a log from Suite (go to settings, click three dots in the header) https://trezor.io/support/

Did you end up getting this sorted? I am having the exact same issue!

Hi @lttj1 refer to this topic please,

you are using wrong format of the address:

Not according to this! Cash Address Converter | Tools | Bitcoin.com

I’ve tried the legacy address anyway. That doesn’t even get past the UI check to let me hit the green “review and send” button. The CashAddr does. And it still doesn’t work. The issue must be something else.

Can you think of another cause, if the address is correct? Because I have tried that avenue and it isn’t the source of the problem.

Legacy address will not work, for the cash address you need to include bitcoincash: prefix in front of it