My MetaMask can't find my adress with NFT:s

Hello guys. Hope you guys can help me. So I had some valuable NFT:s that I didn’t want to to have laying around on OpenSea, so I bought myself a Trezor. Before I moved anything I reset and restored the wallet multiple times to make sure everything was correct and it worked perfectly. So I moved my NFT:s from my MetaMask to the Trezor.

At one point in time I had trouble with my MetaMask, it couldn’t connect to certain sites, so I updated it to the latest version which helped but now that I want to connect my Trezor to MetaMask the adress where I have my keys doesn’t pop up? I have only NFT:s in this wallet, no ETH? Could that be an issue? I know that my seedphrase for Metamask is correct cause I recovered it. Works fine. And I know my seedphrase for trezor is correct as well cause I double checked it in the Suite app.

What am I doing wrong here? Please help!

Hi @mike45,

If you are sure the recovery seed stored in your Trezor is correct, then the only way how to access a different wallet (with different addresses) within this recovery seed is with a different passphrase. Can you confirm you use a passphrase feature?

Generally, when the same recovery seed is used and the same passphrase is entered, the same wallet (with the same set of addresses) is accessed. There is no exception, the public-key cryptography ensures it generates always the same result.

There is a simple way how to verify you use the right recovery seed. Please double-check that the recovery seed stored in your Trezor device matches your recovery seed backup (the one you created when initialized your device for the first time). You can find instructions on how to perform this check here:

for Trezor Model One:
for Trezor Model T:
for Trezor Safe 3:

In case recovery seed in your device really matches your recovery seed backup, the only way how to access a different wallet (with different addresses) is with a different passphrase.

Hello radekP.

Thank you for your answer. Yes I am 100 % sure that my recovery seed is correct cause I have double-checked it inside the Trezor Suit multiple times. I just did it again and the verification came out successfully. This I knew before as well cause I recovered my trezor multiple times before I transferred anything over to it, just to be sure it was correct. So something like this wouldn’t happen.

I have not used any hidden wallet to store my NFTs in either cause the trezor worked fine for a period of months. I staked my NFTs and approve multiple transactions with the trezor and I have never once used any seedphrase to confirm anything. Only my device PIN, thats why I’m so confused.

Can it be anything else? Cause this really doesn’t make any sense. :frowning:

You mentioned you cannot see the desired ETH address with your NFTs in the list of addresses in the step “Select an account”. It means that you are in a different wallet (with different addresses). All information in the previous post is valid. If you are sure that the recovery seed stored in your Trezor is the correct one, the passphrase is the only option how for accessing a different wallet with this recovery seed which means you had to use a passphrase when you created the wallet that includes the desired address. Try to use your PIN, maybe you entered it also in the passphrase form.

radekP, my guy. I’m not joking when I say that you helped me change my life today. There is so much money on that trezor and your tip worked. I got in. Thank you so much. I am forever grateful <3