Metamask NFT issue

Hi All, I have a Trezor wallet linked to my metamask.

It has been working great BUT, I transferred an NFT to the Trezor address and now its stuck.

I cannot transfer it back out. I get various errors depending on the way I try to transfer the NFT but its usually something along the lines or “metamask signature error”, “Not supported on this device”, “internal error”.

Is there any way to save my NFT. It has a fair but of market value and Im really hoping its not lost.

I got it solved. It required me to buy a Ledger Nano X. Here’s how I did it. I set the Ledger up with a new address and downloaded the app for windows(Not sure If this was necessary to install the software properly?). I then reset the Ledger and the application separately. Without plugging the device into my computer, I scrolled to import with a seed phrase(on the Ledger device). It had me set up a pin first, and then I added my Trezor 12 word seed(had options for 18 and 24 word). After I was finished inputting that, I then went to settings/security and selected the add a passphrase selection. I selected the option to add it to a pin number. After setting one, it had me confirm with the first pin I had made. After that I put in my Trezor hidden wallet passphrase and confirmed it. I plugged in the device and opened the Ledger app on my computer. The device asked for the pin and instead of putting in the first one, I put in the new one I made for the passphrase. The device unlocked and connected to the computer. I used the Ledger app to install the ETH App onto the Ledger and then selected it on the device. On the computer, I signed in to Metamask and deleted my Trezor wallet. I then went to -add a hardware wallet and selected Ledger. My hidden wallets were listed and after importing I was then able to see my NFTs in my Opensea profile and sign transactions on the Ledger device. The Ledger device started overheating and acting funny after it was fully charged. I’d suggest having it about 50-60% charged when doing this process as it will continue to charge when it’s plugged in to the computer. I didn’t have to, but I moved all my NFTs back to an online Metamask. After spending a month wondering if I was going to ever have access to my investments again, I kinda soured on the whole hardware wallet experience. Trezor should work on NFT compatibility and also recovery options. I’d suggest a way to view your private key on the wallet after unlocking it. That way it can be restored to an online Metamask wallet. Without that option, I won’t be putting any crypto on Ledger or Trezor hardware wallets. . I watched a Elon Musk live stream on YouTube the other day, along with the CEO of Twitter and some other big wigs. They were talking about developing hardware wallets. Trezor might want to get out in front of this instead of ignoring the relevance of NFTs because you’ll soon have competition. I imagine hardware wallets are gonna look a lot like smartphones so people can view their NFTs in addition to holding tokens. One thing Elon Musk made clear is that people need to be in control of their own private keys.


I see you’re posting this solution in several forum threads. Although it’s great that other people get to know one possible solution, your specific solution involves switching to another product than Trezor and that’s really not a solution for people who use, and want to continue to use, Trezor. So this is outside the scope of the Trezor forums.

Besides, please consider splitting your text into paragraphs, because the current is a wall of text and less readable.

Thank you for your understanding.


Hi @BunCha,

Idk whether you have the issue solved or not. Should you haven’t, kindly see my notrs below.

I had same issue this morning. Same message ‘You declined the action in your wallet’. FYI, this is my chronology.

  1. Send small amount NFT to trezor on metamask to test
  2. Send back succesfully from trezor to metamask on opensea
  3. Send big amount of NFT to trezor on metamask
  4. Can’t send back my big amount of NFT to metamask

I found 3 alternative solutions on problem no 4 above, on this forum and reddit :

  1. Connect your trezor account to MyEtherWallet and send NFT from there
  2. Import your trezor seedphrase to other NFT supported wallet such as metamask, trustwallet, or other hardware wallet
  3. Update the firmware of trezor to the latest version

No 1 and 2 solution didn’t work for me. Eventually the easiest solution which is no 3 worked for me.

Hope you can solve the issue soon.

Happy to help should you have more question.

Thank you