Metamask Error info: there are no keyrings

I have a problem with a Trezor address connected via Metamask.

I am unable to transact via Metamask. And the address does not appear in Trezor Suite.

I created this address directly through Metamask and not in Trezor Suite. I created other addresses in the same way and they are working normally.

I sent some tokens to this address. And now I can’t get it out. Tokens normally appear in Metamask. The address appears in Metamask as well.

I tried to connect to Trezor via Rabby wallet, but the address does not appear in Trezor’s address list.

The first error I see is that when making the transaction via Metamask, the Custom Nonce appears 0 (zero).

When I confirm the transaction, the windows to export public key and the pin to access Trezor appear.

Then the browser closes and does not open again. And the following error message appears in Metamask.

Transaction 0 failed! Keyring Controller - No Keyrings found. Error info: there are no keyrings.

I ask for your help.

Hi @celsorochacoutinho,

from your description, it looks like you accessing a different wallet (that is why you cannot see the ETH address with your funds in Trezor Suite and in Rabby). Please, try to connect your Trezor to MetaMask once again, information on how to do it can be found at

Can you see the desired ETH address in the list of ETH addresses in step “Select an account”? If not, it means you are connecting a different wallet to MetaMask. Either you have a different recovery seed in your Trezor or you use a different passphrase.

Generally, when the same recovery seed is used and the same passphrase is entered, the same wallet (with the same set of addresses) is accessed. There is no exception, the public-key cryptography ensures it generates always the same result.

In case you have the right recovery seed (which is stored in your Trezor device), the passphrase is the only option how you can create a different wallet within this one recovery seed. Every passphrase creates a unique wallet (1 unique passphrase = 1 wallet). Please remember that a passphrase can be any word or any set of letters (in ASCII format and with 50 characters max), it is case sensitive, and empty space is also a valid character, please also think of a different keyboard layout you could have used.

There is a simple way how to verify you use the right recovery seed. Please check that the recovery seed stored in your Trezor device matches your recovery seed backup. You can find instructions on how to perform this check here:

for Trezor Model One:
for Trezor Model T:

In case recovery seed in your device matches your recovery seed backup, the only way how to access a different wallet (with different addresses) is with a different passphrase.

Hi @radekP

I managed to find the problem.
I was using a different passphrase to access the ETH address.
Now the problem is solved.
Thank you for your help!

1 Like