Metamask doesn’t recognise Trezor address

Hi guys, I just set up my Trezor T on a new laptop… I have a new Metamask extension installed as well.

Wanted to send some ETH from my old Metamask on my older laptop straight to my new Trezor address, but Metamask shows that address as “invalid”
Can I not send from Metamask straight to Trezor?
How does Metamask recognise as “invalid” if it is actually a correct address starting with 0x…?

Thank you so much.

Hi @JoMo13,

Sure, you can send ETH from any online crypto exchange to your Trezor.

Difficult to say why, without knowing more about your transaction.
It could be you’re using the wrong Receive address, that you enter the ETH Contract Address instead of your wallet’s Receive address, that you use the wrong network to send the transaction, or something else. You should use the Ethereum network to send ETH.

Edit: Also check that your Trezor is actually connected (green dot at the top of MetaMask plugin) to MetaMask before you issue any transaction. Sadly, Metamask has a tendency to drop the connection (timeout) if you leave it idle for a while.

1 Like

Hi, thank you so much for the prompt reply.
My receiving address is quite simple to copy paste as it’s right underneath the QR code.

The Trezor is not connected to my Metamask (doesn’t have to be I thought) as I am sending the funds from an entirely different laptop and different Metamask straight to my wallet?

It is an ETH address, I double checked on that too.

What strucked me, how does Metamask (on a different laptop) know, that this address is invalid, as it is an ETH address starting with 0x… as prefix and having 40 characters. If the address is wrong doesn’t it get sent anyway and the funds are lost?

Yes, you’re right about that. I use MetaMask (MM) myself, but never used the native/local wallet in MetaMask, only the one connected to Trezor. It’s only when you use MM to handle transactions directly from Trezor that you need to connect the device. (I hope that was correct, because I need sleep now)

If you use it with the native MM wallet, as in your case, it doesnt matter if Trezor is connected or not, since the coins go to the Blockchain and not Trezor. You still need enough ETH in the wallet you send to/from to cover network fees.

If you get an error then the transaction isn’t sent and your funds are not lost.

Could you please provide screenshots of the transaction? You can blur out any sensitive information before posting here.

1 Like

First of all, I really appreciate you for taking your time explaining everything… I hope you had some sleep :slight_smile:
I attached a screenshot where you see that I am on the ETH mainnet. I do have enough gas fees (if I wouldn’t have enough the error would be different - it would say insufficient funds I guess).
I really don’t know why I can’t send any funds to my wallet?
The set up was so easy and smooth but now I am stuck here. I can’t understand how an address can be invalid when it was generated by my wallet during the set-up including QR code.
Do you maybe have any other idea?

Personally, I’ve had this error only once and that was when I mixed up a Contract address and the Receive address for a coin. I put in the former into the input field for the latter. You see in the image below that Contract addresses also begin with 0x…

I guess if the wallet didn’t exist anymore you’d also get that error message. Or if you tried to send it to yourself, in the same wallet.

Other than that, I don’t know what causes the error. You may have to open a support ticket and forward your Receive address to Community support so they can investigate further.

1 Like

Thank you. I really don’t know, but opening a support ticket is probably indeed the solution for this.
It is definitely not a contract address, please see attached.

Just tried to upload a picture here, not working either haha (saying I am a new user I can not upload things although I did earlier in this chat LOL)
Also saying now: “Discourse:InvalidAccess”

did you try any other address? If yes and it is still invalid, then contact Metamask please.

Uploading: 5480.jpg…
Yes, other addresses work. Tried that already.