Metamask does not find my open wallet in Trezor

  1. I am having issues with AAVE and Trezor, since can not sign a contract to close it; Trezor goes iddle each time I tried. AAVE support suggested to reinstall Trezor in my Metamask. When I did that, only the Hidden wallet in TRezor appeared in Metam but not the Open one, where all the tokens are loaded. I connect the hardware again, but appears a long list of ETH addresses, none of which is the one for ETH in my Open Trezor wallet. I read at the blog about seed phrase and passphrase, but none of it is being requested by Metam to connect with the Open wallet.

  2. I transfer the tokens and ETH to the Hidden, but the amounts do not appear in the Hidden; they are still been shown in the Open one. why is that? What I have to do to have the amounts shown at the new destination?
    Please, assist me on how to solve both issues. thanks!

I’m not sure if I understand.
Do you have access to this hidden wallet and the addresses in Trezor Suite?
If so, I think this problem can be solved.

Hi @amartignone,

You can set a longer idle period in Settings → Device → Customization → Auto-lock time.

@amartignone to open standard wallet without passphrase in MM you need to leave the passhrase field empty, if you have tokens in this wallet there is no reason why it would not show up

Also, specify why you cannot make the transaction in Suite? Is there any error? You need ETH on the same address to pay for fees.

Hi @Yamaza! yes, I can see both accounts in Trezor suite, and all the assets in them.
In Mmask I can only link the hidden address, and the Standard does not appear in the list to select/connect.
I open the hidden account after setting the standard, and that mess everything! is there any way of closing the hidden and just keep one to avoid these problems??
Let me know if you figure how to have them both accounts in Mmask or just close one and consolidate them in just one. Thanks!!!

same problem here. using standard wallet but metamask kept freezing, I remember only having a passphrase on the hidden wallet which I can open in suite but when I try to connect my hardware wallet on the other pc my HW address is not on the list. Is this still a passphrase issue? @forgi

if it is not on the list then it is different wallet…I already suggested you troubleshooting for freezing, updates, different browsers, different computers, reinstall…try using MEW