Interaction problems after pairing with Trezor web connect popup

Hi all,

I am trying to send crypto from Trezor wallet on metamask and when I hit confirm on metamask - the window pops up. I’ve paired Trezor but then nothing happens. Picture attached.

Please advise.

All sorted. Had to download a Mozilla browser and do it through it.

I think the issue was when I did export the public keys in Chrome and didn’t tick the box allow always for this device.

Hey i had this same issue. Was waiting for a response on this forum on my post (cant link it otherwise i would) and nobody responded, neither did anyone support via support.

Good to know other browsers work, but this is exactly the same error i had in Chrome, and ive used this wallet with Metamask for years now in Chrome and never had this issue. Sounds like an issue with Chrome to me (and maybe not your box tick theory).

Here was my complaint in detail:

Longtime Trezor Model One owner. Been able to sign transactions no problem in the past via Metamask connected Trezor wallet. Using Ethereum network. Have confirmed latest firmware on device (1.12.1), latest Trezor Suite update (23.12.3), Trezor Bridge is accessible, runing in my processes and updated too (20.0.33)

Today i tried both a Uniswap coin swap as well as just a direct Send transaction to another Eth account. Both times i get the popup window ( that asks you to connect device and pair device. I have ensured the device has been paired (it says so on the second popup…and i even unpaired and re-paired to make sure that wasnt a problem). However, i connect the device and the popup window never progresses, my device just sits with the logo on it.

I go over to Trezor Suite and the Suite recognizes the device, asks for PIN, offers confirmations, etc. and i can interact with no issue.

I had read about the popup disappearing, but never getting stuck on the popup screen. My last transaction was a simple send in Nov 2023, no issues. I have changed exactly nothing since then, other than updates.

I too am having this identical problem. There was no issue up until about 3 days ago.
Can still connect to Suite but when I try co connect to MetaMask it says Trezor is paired but does not advance past that screen. I have tried on 2 different computers using Brave as well as Edge and gotten the same problem as the people above. One of the computers is brand new out of the box. Please help!

Exact same problem but using Ronin wallet for axie. Tried Brave and Chrome, same response Explorers detect the trezor but the pop up doesn’t react to anything.

Last time I used it was on 20/11, hope it gets solved or gonna test mozilla next week maybe that’s the solution as AM2023 said.

Good luck guys!

Tried today with Mozilla and all has worked perfect. There’s a message that says that popup is v8 and should be v9 but ignored it and wored smooth.

So mozilla 1, others XD

Thanks for sharing. Good to know.

Sure would be nice if the other versions were fixed though so don’t have to go about getting set up w a different browser.

To fix the wallet operation, you need to update or reinstall the program Trezor Bridge. I can’t attach a link from the official website, you will find it through the search engine

Did you end up resolving this issue?

I have the same problem where it is stuck at check for devices. Pressing the button does nothing.

This was a Metamask account that was already paired with the Trezor.

Basicly my tokens are locked in the account and cant access them.