I Can't access my existing ronin wallet accounts via chrome extension when I imported my ronin seed phrase in Trezor


When I created my wallet I choose “recovery wallet” Option because I was following a Guide for no reset level axies. So i have to put my seed phrase to sync my ronin account to trezor. Then i have to make a Dummy account at Ronin address so I could connect my main ronin address thru hardware wallet, but i can’t find my Main Ronin Address at the 50 Ronin id list from Trezor.

I tried this process several times, over and over again my ronin address won’t show up,
so I assume I should probably log in my main Ronin address at the chrome extension instead of my dummy account. so i click “Import using Secret recover phase” and then i encoded my Seed phrase so i will able to access my account again. Next thing i know, Ronin Created me a New address with my seed phrase.

If you want to have more information in this story, i posted it on reddit here the link.

My Questions:
How can i able to retrieve my main Ronin address?.
How can i import my assets, If i wasn’t able to see it inside of my trezor wallet?.

I hope we can able solve this together.
Thank you.


I responded to your reddit post, but I will leave the response here as well.

I’m gonna be honest, there is absolutely zero reason to do this. Trying to save the levels of your axies is not worth the frustration and heart-ache of having your assets stolen from you.

You are eliminating the key security measure the Trezor employs by completely keeping your seed phrase off the internet and your computer.

With that said, I am surprised that “importing the seedphrase” via recovery mode on the Ronin Wallet didn’t work. Are you sure you put in the correct seedphrase, and not the seedphrase of the dummy wallet?

Hi Langly1087, I have just subscribed to your YouTube channel, I have followed your instruction to sync the Ronin wallet to my Trezor.

Ronin successfully connected to my hidden wallet, but does not show the AXS balance when the Trezor address is chosen when running the Ronin wallet. I suspect this is because the Ronin wallet has prefixed the address with the word Ronin. My hidden wallet Eth address starts with 0x.

Metamask when synced with my Trezor does show the AXS balance. I have tried my Trezor One and Trezor T. Any ideas?