I cannot locate my Metamask Wallet when I try to import my hardware wallet

Hi guys

I am having this issue just now. I tried uninstalling my Meta Mask extension and installing it again because I have been having issues when Trezor is asking for my public key the pop-up disappears I already tried different methods like incognito or even change browser and allow pop-ups etc it still hasn’t work.

so after uninstalling Meta Mask when I tried importing my hardware wallet I cannot seem to locate the wallet where my Eth and NFTs are located in the options. I already change the HD path I still can’t locate the wallet as well. The only browser where I can see my wallet where my eth and NFTs are located is in my Microsoft Edge browser but I’m scared to uninstall it because maybe I won’t be able to see my wallet ever since I can’t even locate it on Chrome or Firefox already.

I hope you guys found a solution to this if you guys also are having this problem as well and I hope Meta Mask or Trezor can help me.

Thank you