I can not restore my Trezor ronin account after reinstalling ronin wallet

Hi guys Im new here!
After trying to login into my trezor/ronin created accounts (I have watched the youtube guy about create trezor/ronin accounts) and that have help me a lot.
After many tries to login i decide to re install ronin wallet and that worked for me, after reinstall ronin I could restore my ronin accounts but when I tried to import the old Trezor/ronin account (who have some tokens) the account was not there, im tried to find the account whit the account number but the account is gone,
How I can restore my account again?

thank you for help, and sorry for my english!

hi @jhonpsd
I reckon that you are entering different passphrase after exporting your public keys (than is the one you used in order to receive funds).
to get to the same addresses, you have to get to the same wallet, i.e. use exactly the same (or no) passsphrase.
For more information see following threads:

Hi, thanks for a quick response, Im using the same pass phrase i used to import the account into ronin, I have also check the account adress (trezor/ronin) and check the 50 adresses in trezor but i did not find the right account.


As it was already mentioned in one of the threads I shared: that is not possible. When the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

So you are entering wrong passphrase.
Mistyping the passphrase will generate a completely new wallet (with different account and different addresses). There is no such thing as an “incorrect passphrase”, so whatever you provide as your input will be used in the process of deriving a wallet.

Please bare in mind that you could have mistyped your passphrase while creating hidden wallet where is the account you are trying to access. So your only option now would be to guess (brute-force) the passphrase by trying any possible mistakes/typos you could have made.
(e.g. space/blank is a valid characeter…)

Thanxs för helping me, I have recovered mi tokens.
I was only login in whit the password, not whit the passphrase, that was the problem.

Thank you again!

no problem. I am glad you were able to recover your tokens :wink:

1 Like

Hello All.

A follow up on this query please

@Raquell_Malonzo what query? you haven’t submit any :man_shrugging:

Please see below query from the user above who inquired it first.

“ Hi I wondered if the 50 Addresses that we can use when connecting the hardware wallet to ronin is changeable or fixed? thank you.”

Secondly. (I personally use trezor T model) When users use a passphrase, ronin wallet will show 50 different wallet addresses from Standard Wallet addresses. Thus, is this function/s infinite?

I mean, I have tried to use 3 different passphrases. It showed 3 different sets of 50 ronin wallet addresses (excluded the 50 addresses of the standard wallet which passphrase is not used).

I am wondering if using passphrases is safe? As long as I remember my passphrase. Like, I would have unlimited ronin wallet addresses, not needing to buy an extra trezor if I would need more than 50 wallet address.

Pardon me for my explanation. Thank you

that’s already been answered in this topic (that has already been shared in this thread as well btw).

And yes, by using passphrase feature you can technically generate infinite amount of addresses.

Ahh yes. I have also read Trezor’s abouts last night and all my concerns were answered. Thank you for your response as well.

1 Like

does anyone has the same issue? i reinstall it because i have troubled sending my slp to binance. then after i reinstall it my accpunt was gone. i create a new hardware wallet from trezor, when i create a wallet my account at 50 ronin accounts was not there.

if anyone know how to bring back my accounts comment asap thank you!

Hello! I have the same problem… how do I find the recovery seed for my trezored-ronin account? I’m pretty sure I typed in the correct passphrase and recovered all non-trezored-ronin accounts.

did you reset your trezor or what ? why do you want to find the recovery seed for your trezored-ronin account ?
the recovery seed is the same as it when you set trezor at first time you wrote down.

Please note that Trezor will never reveal you the recovery seed more than once (at the beginning during the initialization process).

hi i have the same issue. how to remove te passphrase? i new in trezor can you help me?

do you reinstall te trezer suit?

you can’t remove passphrase once you have created it, you can only find the correct one to enter the same wallet

hi can anyone help me with my problem. I can;t find my ronin address in my trezor after i recover with my seed phrase. I already try to wipe my trezor thrice and I try to recover standard and advance recovery. still can’t find my address in 1000 ronin address