HELP please tech idiot here

Hi , so about 3 or 4 years ago I bought a Tresor in order to store 2k worth of Theta in the hope it might increase in value . … Yesterday I thought I better open up the thing and see if its still there and what its worth . I have a new computer so I download the Trezor app and plug in the device . I enter my pin number and voila im in… But it’s saying the wallet has only just been created in 2024…AND no theta showing at all… ! strange though that it says I have like 1 dollar of bitcoin …It is also saying that there is 0 hidden wallets . It asks if I want to create a hidden wallet . But I dont . I want to find where my theta is hiding .
. In my little box that I keep the Tresor in there is two little booklets that say ‘recovery seed’ on them . One has 12 words on it … without a pass phrase. The other has twelve DIFFERENT words on it WITH a passphrase on it . … … I click ‘check seed’ and type in the 12 words WITHOUT a pass phrase because no where is it asking me for any passphrase . . .?? SO …question is Where is the bit that asks for a passhrase ??? Where is my Theta … … What does it all mean … How do I access it . Many thanks for any help on this … pleeeeeease… I have tried reading through the topics but im scared of accidently wiping away 2k worth of theta … so thought I better ask here first.

have you tried doing a seed check on the device, to see which seed is inputted.
Although that is probably incidental. Although would be useful to know in case a wipe occurred due to firmware update or something.
I’m not very familiar with theta to be honest.
So probably better someone else comments on your situation.

Can you remember if you used a passphrase or not?
Did you note down the address of where the theta is held?

After some googling, it looks to me that theta is not supported in trezor suite…
It looks like you need to go here and connect your trezor (with the correct passphrase or not if you didn’t use one):

Good luck

1 Like

thank you for your response . I checked the first seed and it didnt need a passphrase. Although it said it was correct seed still no Theta appeared … I dont know if I am allowed to try the second seed too (the one that has a passphrase written down next to it on the little bit of cardboard ) or will that mess everything up . I will try the link you sent thankyou

I don’t understand you:
‘first seed didn’t need a passphrase.’

every seed can be used with a passphrase or not, in fact an almost infinite number of passphrase combinations and unlimited number of passphrases could to be used to generate billions of wallets.

the question is: the wallet you sent the funds to, was that wallet a no passphrase wallet or a wallet with a passphrase?

Theta will only ‘appear’ when you are connected to the correct software (and seed etc), trezor suite is incompatible with theta, so it will never appear there…

1 Like