First firmware. Stuck at 90%

Long story short I bought trezor 3 and always stuck at 90% in install .

I changed computer from Mac to windows.
Download with bridge.
Different broswers.
New clean coockies. Nothing working! What’s wrong ?

1 Like

Hi @Partolis,

First, please try to factory reset your Trezor device. Please, keep in mind that to reset the entire device (including the firmware), the factory reset needs to be done from the bootloader mode. Instructions on how to factory reset your Trezor can be found at
(the process is the same as if you forgot your PIN).

If the issue persists even after the factory reset, please reach out to support via the chat speech bubble in the bottom right corner on the following page:

Once you will get your ticket number let me know here.

I have trezor safe 3 and not working.
Also is my first time I’m trying to install the firmware. Is new device never done anything with it before. Is broken or what ? Is the firmware universal 2.6.4

Have you tried factory reset as described in the previous post? If so and the issue persist please contact support as described there.

Hi, unfortunately I have the same problem as you. Did you solve it somehow? I tried asking the chatboat for help but it’s useless. thanks

Hi @PieroM,

If you have the same issue, the same answer for you: First firmware. Stuck at 90% - #2 by radekP