Error message Metamask not support

I’m using trezor 1 and tried to sign with collab land from discord to verify wallet as I’m holding some NFT but I got error message below.

“MetaMask Message Signature: Error: Not supported on this device”

What should I do?

My firmware version is 1.10.5

I did many time before and it was fine. I’ve asked support of NFT project in discord and he suggest to asking here. Please help.

My trezor in my metamask dont work, i can´t send any transaction. I have money there and its not accesable… Is this trezor Scam? Next time I rather hold coins on metamask without danger which trezor offering …

it’s Metamask issue, we have made updates on our side, their issue is still open:

Thanks. So I have to wait until Metamask solve the issue right? Or Do I have to do anything?

you can try MyEtherWallet or MyCrypto

100% Trezor issue cuz i try login MetaMask another account is success

what another account? As in you tried with another Trezor device and it worked?

because if you only tried with normal MM account without HW then it’s something different

1 Like

another account Metamask is not connect Trezor
Trezor in Metamask not use Collabland

that is different…

please see the response from Metamask team:

1 Like

Hello, just FYI collab land have a workaround on their twitter until its resolved

basically just replace the connect subdomain with roll in the URL