Error message after update

Hi @forgi,

There’s still the same error after every update of Trezor suite – “Trezor is connected in a wrong state” or something like that. I’ve reported this before through the Feedback & Bug report routine in Trezor suite. I’d advise you to clear the cache after update, so that the user must enter PIN again. Yes, I know we can just press “Use Trezor here” (or similar text), but users are confused by this error.

The process is like this, as far as I remember:

  1. Connect Trezor device to USB cable
  2. Wait for the connected beep from Windows
  3. Launch Trezor suite
  4. Enter PIN on device
  5. Trezor suite says there’s an update and I click Update button
  6. The download and install is performed
  7. Trezor suite is restarted.
  8. Error “Trezor is connected in a wrong state. (Use Trezor here button)”

Also, why aren’t bug reports sent through Trezor suite fixed? Things I submitted a year ago are still not fixed. Even small things that’d take very little time to fix. And since there’s no copy of the report sent to my email I have a hard time remembering what I submitted, so I have problems following up my reports. You’re not making it easy to report bugs.

1 Like

This error means there is another application running that is clashing with Suite, like web version of Suite opened in the browser or Metamask or some other app.

I don’t know what issues you are referring to specifically but everything is reported and tracked here: Issues · trezor/trezor-suite · GitHub

I know, but it’s not clashing with another application, it’s clashing with itself because Suite neglects to close the existing connection to the Trezor device before updating Suite.

I can’t find my submitted bug reports on Github. Is this the only place developers axpect to find bug reports? If so, why do you encourage us to use the report function in Suite?

sorry for the late response. I just tried updating Suite with the Trezor connected and I did not get this message (I did this on MacOS), so if you can reproduce the issue then record a video of it and include all your specs.

Sure, I can do that. It happens every time for me.