Connecting to Trezor emulator using monero wallet

I’m having trouble accessing my Monero wallet on my Trezor T device. Instead of resetting it with the recovery seed (more risk than I’m willing to take), I’d like to access my wallet from the Trezor emulator instead.

I’m aware of the increased risk of having my recovery code / wallet outside of the protection of the device.

I have the emulator running on my Ubuntu Linux machine, but my monero wallet (I tried both GUI and CLI) aren’t able to connect to it. But they’re able to connect to my physical Trezor T device just fine.

I also double checked and trezord is still running so it shouldn’t be a problem. I also downloaded and ran trezord-go (got it from the official Github repo) instead of trezord which comes with trezor suite, but my wallet was still unable to find the emulator.

Monero GUI outputs this when attempting to connect to the emulated device:
|2022-12-24 17:27:12.453|E No matching Trezor device found. Device specifier: “”
|2022-12-24 17:27:12.453|E Device connect failed

Any advice on how to connect to the emulator from the wallet would be great.

That is not really a use case for emulator so I assume there will be some connection issues. You have to make sure you close the Suite, so the bridge is not running. Then restart computer and run emulator and run Bridge from there.

Try shutting down the Bridge. It might be configured to ignore the Emulator, Monero would try to list Bridge devices and give up when none is there.

Other than that, Monero things should generally be able to detect Trezors without the bridge entirely.

I shut down the bridge and made sure it’s not running, but the monero GUI wallet is still not able to connect to the emulator. I also tried using the trezord-go -e 21324 bridge, but that also didn’t work.

Any other ideas on why the wallet wouldn’t be able to connect to the emulator?

I can reproduce the problem too. Not sure why – it’s definitely supposed to work and reading the source code supports that. I will let you know if I find out more.

1 Like


Were you able to find out any more information on this?

So it seems to turn out that you would need a debug build of the Monero binaries to enable the UDP transport. This is not enabled in the official builds (presumably because one isn’t supposed to use the emulator). And while it would technically be possible to run through Bridge, Monero checks the device VID/PID identifiers and the emulator is reported as zero, so Monero doesn’t count it as a Trezor.

Unfortunately, the only thing you can do is build Monero from sources.