Cardano - Cannot Access Public Key with Daedalus or Yoroi

Firmware: 2.4.1
Transport: Bridge 2.0.27
Pin enabled: Yes
Passphrase enabled: Yes

Ticket Id: 92714

My new Trezor Model T has a hidden wallet and I have the seed words. I have the pin and passphrase. I set it up without any issue, sent ada to it, and joined a staking pool using Daedalus.

This morning, I decided to change to a different pool. When I try to change the pool, Daedalus gets to the point where it needs the public key (after I select the hidden wallet, which shows the old pool and ada amount). It tells the Trezor to send the public key. I enter the pin/passphrase on the Trezor whenever needed. The Trezor shows the public key and I select the yes check. Up to then, Daedalus is apparently connected fine with the Trezor. As soon as I click the checkmark to send the public key, Daedalus shows an error “Unable to detect your hardware wallet device” in gray text. Underneath there is now red text that says “Disconnect and reconnect your hardware wallet to restart the process”.

I’ve tried the following…

  • Disconnect/reconnect several times
  • Uninstall/reinstall Daedalus
  • Reset the Trezor and reenter the seed words, same pin, and same passphrase (seed words are correct)
  • Installed Yoroi which tries to read the public key but instead, after clicking the green Connect button, redirecting to the Export Cardano Public Key page (which says “Export Cardano public key for account #1”) and redirects back, it gives a red text error of “Something unexpected happened. Please retry.”
  • Tried sending ada out but cannot do that without the public key

Please help!

Hi @Gary,
thanks for sharing the ticket ID.
One of our agents will reply soon, as we will prioritize your case.

I am having the same issue with Daedalus and the public key error.

I’d suggest you to try different wallet, such as AdaLite: