Can't See Any Assets - Hidden Wallet Issue?

I have only ever used one wallet on Trezor. Within that wallet I had multiple BTC addresses and one ETH address. It had all of my crypto in it.

I was having USB issues connecting my device today (it said “disconnected”) and so I pressed “eject” to try and fix it. At that point my wallet disappeared entirely. I then realised after reading this forum that the sole wallet I had created was a ‘hidden’ wallet but have no memory of every setting it up this way. I never intended on doing this and and the passphrase option was disabled for as long as I can remember having the trezor. I figured that I could just use my seedphrase to recover this but it seems like I need a separate password, so I’ve enabled the passphrase function now to try and get it back. I can’t believe that pressing the ‘eject’ button could have such a massive consequence. No passwords I’ve tried are getting me back into this hidden wallet.

I am absolutely distraught at having potentially lost my entire net worth here. Grateful for any help. Thank you so much.

And to add as a follow up, I installed a software update before doing this and then a firmware update as well. Not sure if this changes anything…

Hi @BenCantor,

I understand that you saw your wallet before pressing eject in Trezor Suite, but …
How did you manage to use your Hidden wallet without login with a Passphrase?
That shouldn’t be possible.

I also find it strange that you created a Hidden wallet without knowing that you did it. That is a special process which clearly notifies you that you’re about to create a Hidden wallet.

And lastly, the Eject function doesn’t remove your wallet or any of its accounts.

Not that I don’t believe your experiences, but something doesn’t add up here.

It depends on how the updates performed. Did you see your wallet after this and then pressed Eject?

This is what I’m struggling with! I assume I must have created a passphrase initially when I set up the Trezor because I know it said I was in ‘Hidden Wallet 1’, but I was never asked to confirm my passphrase through using the Trezor over 1.5 years. On a number of occasions I transacted with this account (although it’s possible I only received funds and did not send any out). I would log in with my pin each time on the hardware device and then just transact normally.

Grateful for any further thoughts and happy to share screenshots if helpful.

that will be the case, you had your wallet remembered in Suite, so you were just looking at it, receiving coins, but never sent anything so you were never asked for passphrase.

Eject “removes” these remembered wallets and you need to enter the passphrase now to get back to that wallet.

Exactly what I’m worried about. I wish there was a prompt or something before you press eject that explains the significance but too late for me I guess… any other ideas here would be much appreciated: (

@BenCantor that is not the point, eject is not significant, the passphrase is.

You were basically just throwing money into that wallet without ever being able to take them out anyway.

The thing is I actually sent LINK out as an ERC-20 token but never sent any Bitcoin out. How could that have possibly worked?!

I think it only asked me to insert my hardware device pin each time