Can't log in to axie marketplace

I’ve been using ronin wallet + trezor for a year now, no major issues aside from the very beginning.
The issues I had at the beginning just came back for the last 2 days:
Can’t log in to marketplace, when I click login with ronin wallet the trezor pop up pops out, I connect my trezor, put passphrase on there, sign etc and then the pop up closes and I come back to axie marketplace and nothing happens.
I already checked did this checklist:

  • cleared cache/browsing data on chrome, used incognito mode also
  • restarted computer
  • checked and trezor bridge status 2.0.31 is connected

Any help really appreciated, thanks!

Please try reinstalling your Trezor Bridge, restart your computer and try using Firefox browser in incognito mode as well.

Which version of the bridge should I have? (I have a mac). I just reinstalled version 2.0.27.
Still doesn’t work.

that’s a stable version of Trezor Bridge so the issue will be most probably in your browser.
Also try changing the cable as well.

Can you please tell me or link me to a thread with all the steps I need to take to make sure the browser (chrome) is “ready” to work. Thank you.

please see following thread:

Also, please try using another supported broser- Firefox as advised.

I tried but it only imported my first account in firefox not the 98 I have on Google chrome…