Can't find metamask account

Hi, I’m using Model T, trying to connect to Metamask but it can’t find my account. I’ve searched the first 500 accounts and it’s not there. Should I continue? No passphrase and standard wallet.

Hi @Matty
The only possible reason for you not being able to find desired address is either different seed or passphrase (or both). As all addresses are derived from recovery seed and passphrase (if used).

There is no point of continuing if you have not chosen custom address_index (variable to get different accounts) in the derivation path when accessing the address in the first place.

Hi MichalZ,
Thanks for responding so quickly. I’m sorry but I don’t really follow. I’ve setup the Trezor wallet and what I’m doing is trying to connect this to my Metamask eth account. I naturally have a different seed for trezor and metamask. Can you explain a bit further? Also, you write “if you have not chosen custom address_index” in the derivation path. At what stage do I do this?

I just realised that I’ve used this account address with MEW and Ledger Nano a while back. Could this be an issue? thanks for helping me!

That is just an optional feature of some interfaces, that you could possibly get into the account more further in the list of accounts derived from seed.
But if you are not aware of this I assume you have not used it before so it is not the issue.

In that case please try to choose different derivation path as shown in the picture below:

Hi MichalZ,
I tried the other two paths to the same effect, but I think I may be misunderstanding the process here. I just saw a youtube tutorial and that guy just picked the first account on the list and it became his Metamask trezor-connected account. The line “Don’t see your account?” above the list threw me off. I thought I was able to connect my trezor to an exisiting meta mask account (where I currently have my tokens). But I need to select to create a new metamask account and then transfer tokens to it for them to be protected with trezor? Is this correct?

That’s correct Matty.

Once you initialize MetaMask wallet, there is a default account created (the red one in the picture). If you wish to use it, then you need to keep your MetaMask seed phrase to recover and access this account whenever needed. This account is not a part of Trezor wallet.

On the contrary, there are Trezor accounts (the yellow and the blue one in the picture).These are Trezor generated accounts and can be recovered (and you can spend from them) only by using Trezor recovery seed.

So you can’t just connect your Trezor to existing MM account. You have to transfer the funds from this default account to account linked to your Trezor (as it’s addresses are derived from Trezor recovery seed, not the Metamask one…)

It worked. So I have a Trezor account on Metamask now, it says connected to hardware so all is good. Thanks!

No worries, I am glad you managed to resolve the issue :raised_hands:

1 Like

Hi MichalZ,

A follow up question. If somehow my MetaMask wallet gets compromised (gain access to my seedphrase, computer hacked) a hacker still can’t access my funds in the Trezor account since they can’t sign any transactions, right?. So in this case I can create a new MetaMask wallet and import my Trezor account to this one. Correct? Or is there a way that a hacker can block this transfer even if they can’t access it?
Thanks for answering my questions.

trezor account seedphrases are in trezor ,how can a hacker gain access to it ?

Hi Matty,
You are correct! Since each transaction must be signed by using private keys of the respective address even if your MM wallet would get hacked, attackers would not be able to transfer any funds from the addresses derived from your recovery seed.
And yes, you could create new MM wallet and import your Trezor account there afterwards.

I am having a similar issue. I currently have a trezor 1 connected to meta mask. I connected my Trezor and clicked on the first available ETH address. It created a wallet called “Trezor 1” with (hardware) in gray beside it. Then I sent assets to the new wallet from my existing meta mask wallet. I can see the assets in the metamask wallet titled “Trezor 1” . I cannot see this wallet in my Trezor suit app. I also cannot send my assets out of my Trezor meta mask wallet. It freezes every time I try to send.

hi @Qtip,
You have to use exactly the same combination of seed phrase and passphrase in order to access desired wallet and its addresses and also to be able to spend from them.
If not, previously created account in third party wallets will become watch-only (you can see your funds but you can’t spend them as required private key is not used).
This issue has been described in so many threads here already, such as this one:

So my understanding is that I would need to delete my trezor suite wallet I initially set up and then enter in my mm seed phrase into trezor suite in order to access those wallets? Would that delete my assets currently stuck on that mm wallet that says trezor?

No that won’t be of any help as you are trying to access the address derived from your Trezor recovery seed and Passphrase (if enabled and used), not the MM one.
The only solution is to use exactly the same combination of recovery seed and passphrase as you did when you generated the address in the first place. You can conveniently check if you used right “formula” when you use Trezor Suite - the ETH address you would see there has to match the “Trezor 1” account in Metamask.
Alternatively you can also use following tool:

Yes but my Trezor 1 wallet in mm doesn’t appear in Trezor suite. When I try to send I don’t even get to type in a passphrase before it crashes. When you say “The only solution is to use exactly the same combination of recovery seed and passphrase as you did when you generated the address in the first place” When exactly do I type in my seed and passphrase in this whole process? I can’t do that if everything freezes and crashes before I can type anything.

I have no idea where I am supposed to enter in my seeds. I have all of them to try but there isn’t a clear answer as to where I am supposed to be inputting them.

if the Trezor 1 address you are trying to spend from via MM does not appear in Trezor Suite you are using different combination of seed and passphrase.

You do not type your seed anywhere. You just have to use appropriate private key.
These private keys for signing transactions are derived from the combination of seed stored on Trezor device and passphrase (if enabled and used).
Hence, if different seed (different device) and/or a different passphrase is used then the private key differs and cannot be used. In such case, previously generated wallets/accounts in third-party apps would become watch only wallets without the possibility spending the funds as stated before.

Please try to connect your device to MEW using exactly the same seed (device) and passphrase (if enabled and used) as you did when you generated that address in the first place.

Hi MichalZ,
Great to hear, now I feel safe and happy! Once again, thanks for all your help :slight_smile:

1 Like