Cannot Input Particular Seed Passphrase Word on Device

Trezor Model T
Firmware: 2.4.3

I am trying to check my backup using Trezor Suite. There’s a word in my seed that contains two letter "T"s. When I input the first letter “T” on the screen, it disables the “tuv” input block and now I can’t input the second letter “T”. How can I continue the passphrase check?

Hi @CentauriEx

Are you sure that you are entering the word in the correct way?

Please note that when you are typing the words (for seed check or recovery purposes) it does not use the predictive text technology in a sense of single tapping (of each key representing the letter) but it uses a “multi-tap approach”.

In other words if you want to type for example the word ticket

you would need to:

  • Tap the “stu” tile two times to enter the letter T
  • Tap the “ghi” tile three times to enter the letter I
  • Tap the “abc” tile three times to enter the letter C
  • Tap the “jkl” tile two times to enter the letter K
  • Tap the “def” tile two times to enter the letter E
  • Tap the “stu” tile two times to enter the letter T

Alternatively you can use auto-fill feature after typing just ti since it is the first word of the list starting with such combination of letters:

The words of your recovery seed are drawn from a finite list (link below), so your device can predict the word and offer you a suggestion. To confirm, tap the tile with the suggested word in the top-right corner of the touchscreen.

Hi @MichalZ

Yes, I am sure that I am entering the words correctly, as I have been entering the other words as well correctly.

The problem shows up for words with a succeeding same letter. For example the word “cattle”, I am able to enter “cat” successfully, but after that, the “tuv” tile is now greyed out and disabled and cannot be tapped again, and there’s no suggested/predicted word yet so it’s now stuck.

I can show a video of how it’s happening if needed.

You’re using the Shamir restore, whose wordlist is different and the keyboard also works differently.

In particular, the key tuv exists on the Shamir keyboard but not on the BIP-39 keyboard, where the key is stu.

The word cattle is from the BIP-39 (Single backup) wordlist, which should have 12 or 24 words (18 in case you initialized your Trezor through Exodus Wallet).

If you select incorrect number of words at the start of the recovery process, in particular if you select 20 or 33, then Trezor will expect only words from the Shamir wordlist.

2 Likes

I see, thank you. I do have the Shamir restore.

Here is the Shamir wordlist: slips/wordlist.txt at master · satoshilabs/slips · GitHub
In this wordlist, there are never double letters – in fact, there are never two consecutive keys to be pressed.

If you have a Shamir backup and one of your words has two of the same letter in a row, that is a wrong word and you will need to try to find the right one.

Hi guys, @matejcik,

I´m trying to use my first hardware wallet Trezor T and as my friend recommended I deleted everything to “factory settings” to be sure I´m able to recover it. While putting there 20 words of the first share (using Shamir) in one of the positions it should be “empty” but after writing e m p it suggests me “fluff” and there is no way how to put it correctly there . What should I do?

Regarding the last post, I have 1-3 of the 20 words with double letters. You can see that in the wordlist anyway.

Thanks!

Petr

You are right, I misspoke. What I meant was, there are never any doubled letters among the first four. So class is a valid word, and clas has no letter repeated. Plus, you always need at most four keys to enter the word.

Double-check the keys you are pressing. “Fluff” starts with ef klm tuv. “Empty” starts with ef klm nopq. If you mistyped “Emty”, you would get “fluff”.

1 Like

Successfully recovered, thanks!

I have the similar issue. I need to enter a share (using Shamir), I chose 20 words, and once I have to enter “roaster” I cannot since after I click rs nopq ab rs Trezor suggests “spark” instead. As far as I understand “roaster” word is from BIP39 list, and “spark” is from “SLIP39”.

I tried to reset Trezor to factory defaults and create new 3 shares using Shamir. But again it generated the word “roaster” inside the seeds and again I cannot enter that word.

P.S. Trezor model T with firmware 2.5.2

@blade hiii!!

I have gathered some docs that could help understand your issue better

Shamir backup

Shamir wallet recovery

Recovery shares bear some similarities to the BIP39 recovery seedgenerated during the single backup process. A recovery share is a sequence of 20 or 33 English words carrying a part of the cryptographic secret. Combining the necessary number of shares creates the master secret (seed) needed to recover a wallet

  • Shamir Backup uses a different wordlist than BIP-39 recovery seeds. In other words, some of the words used in Shamir backup recovery shares are never used in single seed backups and vice-versa.

Have you read the above posts?
Look for matejcik he is a developer and has some explaination on shamir maybe it can help.
Like keyboard

So check his posts above (if you haven’t allready) on this as they can be helpful.

Also here is an trezor oficial video

If roaster if a bip39 word why are you entering this as a slip39 shamir share word?
Are you sure you have the right share?
Not mixed up with another wallet recovery/seed words?

Well I hope this helps
:crossed_fingers:

Hi @rimas
Thank you for your answer. Unfortunately, it didn’t help.

If roaster if a bip39 word why are you entering this as a slip39 shamir share word?

The first question is for developers of Trezor’s software. I have no idea why it generated bip39 words inside Shamir shares.

Are you sure you have the right share?
Not mixed up with another wallet recovery/seed words?

Yes, I’m sure. I don’t have other seeds/shares since I used a brand-new Trezor device for the first time in my life. I created a new account using 3 Shamir shares that the device generated. And then I tried to check Backup setup. And couldn’t enter that “roaster” word in a 20-word sequence. Then I tried to Factory reset it and generate new shares. And again in the new shares, there was “roaster” word that I couldn’t enter when checking Backup or when really recovering my Wallet.

@blade “roaster” is not a word in either bip39 or slip39.

So you have a completely wrong word. Just wipe the Trezor again and generate new shares.

Here are the lists:
https://github.com/bitcoin/bips/blob/master/bip-0039/english.txt
https://github.com/satoshilabs/slips/blob/master/slip-0039/wordlist.txt

1 Like

@rimaS and @forgi Thank you both. There is no bag on Trezor’s side.

It turned out that my brain played with me. When I was writing the 1st share I mistakenly read “roster” as “roaster” and then I misremembered it and following 4-5 times I wrote it down incorrectly as well.

Today

  1. I checked that “roster” works for recovering the wallet
  2. I also tried to generate a new Shamir share and Tresor indeed used the word “roster”.
2 Likes

Great stuff @blade

:ok_hand: