Address unknown trezor metamask ▫

Are you checking “IN” transaction on BSCscan? I check already ,It do not have “IN” transaction.how about you?

Hi, I’ve recently got my trezor and have started using it.

When I set up the hardware wallet on Trezor it seemed very easy and I transferred my coins into it. I did a test run and transferred 1 token into hard wallet and then sent it back out to my other soft wallet. I then proceeded to transfer it all to trezor hard wallet.

However, upon trying to send some coins out from my wallet I get the attached failure.
unknown address

I believe it has something to do with the passphrase. I didn’t think there was a passphrase set up, but there must be because each time I use metamask it always ask for a passphrase when trying to make a transaction. So I may have just typed a random word to test it and I am now trying every single passphrase I could have used and it is not allowing me to send.

Could this happen because of the incorrect passphrase, or could it be something else?

Please help… If it is the passphrase I will create a excel sheet of thousands of words and go through one by one. If not and there is another solution I’d really like to hear.

Thank you.

Hi @nodes,

Please see Pavel’s responses earlier in this thread.

2 Likes

The same error always appears, error 0 unknow adress

I have the same problem. Trezor Model T, MetaMask, ERC20 network sending any ERC token. Error: Unknown Address.

This CLEARLY is a problem of Trezor. Because MetaMask is Metamask. This happens with Trezor only. People are losing major amounts of their assets because of this bug. Please provide us an answer and a solution. Or is it time to very loudly move to Ledger? Please help.

Another user found out that his problem was the Passphrase feature. Basically, the state it was in when you created your wallet on Metamask. So you can try this and see if you have the same issue:

If you had enabled the Passphrase feature in Trezor when you created the Trezor connected wallet there, you must have this feature enabled later to see your funds - regardless if you use the feature or not.

Vise versa, if you didn’t have the Passphrase feature enabled when you created the Trezor connected wallet on Metamask, then you must have this feature disabled to see your funds on Metamask.

I’ll have to add that I’ve not tried this myself so I can’t say if it’s going to work, but it’s worth a try.

Hi all I have the same problem as nodes.
I set up the trezor. Test sent to and from it over a few different days before I started to add coins.

I remember seeing the password option and avoiding it.

Now all of sudden I get asked for a pass phrase that I did not set up as far as I can remember. I can still see my coins in metamask.
Any ideas at all please to try?

Exactly where do you get the question about Passphrase?
If it’s on the Trezor Connect page when you login to Metamask, then just enter blank (nothing) in the Passphrase field and then click the green Enter button below.

Hi. I have the same problem with my metamask and trezor.
I sent all of my coins of the account 1 in metamask to the hardware trezor 1. After this, I can’t do anything. My coins can’t move between my own account or to another place. A message appear “ failed transaction error error unknown address”
Please help me!!

I have the same problem!!! Somebody help you??

Thank you

Hi Petosiris
When I go in to my metamask, my trezor is not connected. I see the account I want and try to send coins from the account. It tells me to connect trezor, and then it asks for a password. If I leave it blank it still says the same error error message if I try to guess the password. (I have guessed all possible passwords I use incase I somehow added it in my sleep :slight_smile: )
Thanks you for your help.

Pavel, hi my name is Federico. I have the same problem with my trezor T.
I ve send all of my coin in my metamask for (account 1) to (trezor 1, hardware wallet). I can’t move my coins from trezor 1, hardware wallet.
“Error error address unknown”
Could you help me please!!
Thank you

I linked my Trezor to my one (1) metamask wallet. I transfer all my tokens on that wallet (Hardware Wallet) Now im trying to send some tokens to my other wallet (Same metamask account, TRANSFER BETWEEN ACCOUNT, but not connected to hardware), and i keep getting Transaction fail “unknown address”

I’m trying to transfer BNB / SKILL (Cryptoblades) and PKMON (Polak Monster) token and it keeps failing.

2 Likes

same thing has happened to me, but on the ETH network.
I still am able to receive in the hardware wallet, but not send.

@Kylochu , were you able to solve your issue?

1 Like

I have the same problem, did you find a solution?

I have the same problem, could someone move their funds?
thank you

I’m shocked with Trezor’s disrespect with its customers…

It has been weeks that me and dozens of others have been asking the same questions on this thread and Trezor’s team clearly IGNORES us all, asking the same questions to the void and urging for a help that never comes…

We trusted this company and product with our savings and now they just pretend that they’re not seeing this product issue OR repeat a pseudo-solution that doesn’t work.

Is it that hard to get some engineers/product managers to jump into a call with a couple of the affected people to investigate the issue and then provide us an official status of the issue or immediate solution?
Is it?

1 Like

@Wally11,

I just wondered if you got that question about passphrase on the Trezor connect page or from Metamask. Note that there’s a difference.

If you don’t made a passphrase, then on the Trezor connect page you can enter it blank (nothing). If you created a Passphrase in your Trezor device, you have to enter the correct passphrase if you connect a Hidden account to Metamask. The Passphrase is case sensitive, so large and small letters are different. Space is also a valid character.

Also, as I said above, enabling and disabling the passphrase feature in Trezor Suite may be a solution.

Trezor Connect passphrase dialog looks like this:

1 Like

Hi @fechuday @gustavoh @Kylochu

First of all, please, keep in mind, MetaMask is a third-party app which we do not develop, neither maintain.

Anyway, I’ll ask you for sharing your addresses via PM if possible so we could have a look whether the issue is related to EIP-55 checksum address format.