Address are missing

I rebooted my PC and surprisingly, my address are missing. The imported from Trezor are now different when I connect my hardware wallet (T-One) to MetaMask. Using Standard and Passphrase. Not sure what happened here. I’m using MetaMask. How’s that possible? Already tried in other browser, but Trezor generated different address. So all my assets are now gone? I thought having hardware wallet is secured.

1 Like

Hi @btgomez3

If you are using same device (same seed) then the only possible reason could be the passphrase feature.

Please note that once the passphrase feature is activated on the device, you can provide any input of your choosing and it will be used to generate a completely new wallet. To access this hidden wallet repeatedly, you will have to use the exact same passphrase in combination with the recovery seed on the device. Using the same seed with a different passphrase will generate a different wallet. Using a different seed with the “correct” passphrase will generate a different wallet.

we have same problem. did you already fix and recover yours?

2 Likes

is there any way to recover my assets? i had correct recovery seed and i didnt input passphrase during i created my metamask wallet inside the trezor still i dont find my address

1 Like

Please, see this post explaining MetaMask accounts.

No, even I input the correct passphrase. I know it is correct because it is written along with my seedphrase and test it several times before I put assets in it.

Are your funds on Ethereum Mainnet? If so do you see desired account in Trezor Suite ?

0x3ec…ed8E9 - Trezor hidden # 1 (From Trezor)


And those are the list of generated accounts using my passphrase. I always save everything.

If you have previously used first ETH address and now when you are trying to access the same address the first one is different then you are accessing wrong wallet. There is no other explanation for that.

Because when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Suggest viewing my topic as well.
From my point of view the problem is that updates, both - firmware and software, don’t catch the wiki. And information often is in different places that are not connected well. User experience is the proof.
Also, for myself, I decided not to update firmware on a wallet with funds, but rather transfer them to updated new wallet. Only then - make an update.

1 Like

Hi @MichalZ , having the exact same issue and zero luck fixing it with all your recos on the forum.

Could you DM me please? I can’t seem to message you for some reason, desperate for help

Hi @jvm8
Could you please submit a request using this form and get back to me here with a ticket ID ? Thank you.

Hello Trezor team,

I have the same problem and I think there are a lot of people having the same problem as mine. The same thing happen, used my trezor on my other pc after logging in, connect my hardware wallet, then trezor make me choose a wallet address on the list provided, so confident about how trezor works, I transferred all my asset into the hardware wallet that is provided by trezor then after that, when I want to send my asset back into my main acct, metamask freeze, always prompting me that my transaction failed!, I thought it was my pc that has a problem, so I logged in to my laptop, enter my seedphrase acct1 appears then connected my hardware wallet then the wallet address that trezor provided me is not on the list! 0xB3382ce7526DaDc856Da8E5C928568d123aB7C54 that is the wallet address that is missing. Trezor kept saying seedphrase passphrase problem! I think it’s not. the hardware wallet is missing! how is it possible that the wallet address provided by TREZOR gone. please TREZOR support can you give us a proper answer to this issue. If 12 thousand of us having the same issue missing address say every address have 1000usd worth of asset that’s 1.2million worth of asset gone missing, maybe you can touch base with metamask support to resolve this issue, that none of you on the team gave a concrete solution. I am telling you it’s not seedphrase nor passphrase is the problem because people are not dumb to not write down those, because that’s their security. I hope you can answer our main question. WHY ADDRESS WALLET PROVIDED BY TREZOR GONE MISSING ON THE LIST EVEN WE KEY IN THE PROPER SEEDPHRASE OF OUR MAIN ACCOUNT?

Thank you trezor support.

2 Likes

have 12 Account created on Trezor ronin Wallet then i accidentally created 1trezor metamask account that replaced my 1st Ronin wallet in trezor. now i cant claim my assets on the 1st account because the address has removed on my trezor wallet and i cant find it…
can i recover it ?

if there was any issue with our or MM SW then everyone would have the issue. even 12k people is a very small percentage.

Even on this forum you can find stories of people who swear to god they do have correct passphrase or never created one only to actually find it after.

Nothing can go missing because it is derived from the seed.

@forgi so yeah as expected, you blame the user for the problem even if in plain sight my hardware wallet address is missing. now I am losing hope in retrieving my hard-earned asset. My question is simple, “how would it be possible that my wallet address created by trezor to go missing”. I use Binance smart chain and I don’t use MEW or bitcoin wallet.

it is not missing, it is different…

it is not possible, everything is derived from the seed and cannot change or go missing

feel free to point out exact problem/bug in the code, it is all open source and available to you or anyone…

When I enter my master seed and access my trezor wallet, if I am not mistaken, BIP fortyfour and trezor testnet is only showing, not that BIP-thirtytwo

that was an example…

feel free to look into any technical details here:
https://github.com/bitcoin/bips/blob/master/bip-0044.mediawiki#Examples
https://wiki.trezor.io/Cryptocurrency_standards#BIP44

what you saying would effect everyone and not just small percentage of people…

I dont have bitcoin wallet on my trezor only metamask wallet that is connected to hardware wallet, and that is the one missing. none on the list of thousands of wallet address on my trezor.
image

acct 1 is my wallet from metamask then trezor is my hardware wallet, i cant transfer my asset on trezor to acct 1