AdaLite - passphrase


I’m using my first Trezor device (Safe 3). Previously I was using Ledger Nano X and I want to gradually transfer coins from old Ledger wallets to new Trezor wallets. Of course on Trezor I created new wallets and also new passphrase. On Ledger I was used to enter passphrase only once for session - for example I entered PIN, then passphrase (only temporary, not attached to PIN) and I check everything on Ledger Live. Then I went to AdaLite (for my Cardano wallets) and accessed wallets via Ledger. The only thing I had to confirm was public keys extraction, but nothing else. Today when I tried to do the same with Trezor (unlock trezor with PIN, then check some other stuff on Trezor Suite app - of couse after entering passphrase on device) but when I went do AdaLite page and tried to access wallets I also have to confirm public keys extraction but also I have to enter passphrase (on device of course, but it was redirected via connect(dot)trezor(dot)io). Is this ok? Or I did something wrong? I just want to be sure my wallets are safe and as I mentioned, I never have to enter passphrase multiple times for the same session on Ledger.

Hi @allidan3373,

I can confirm that this is a standard behavior. Passphrase needs to be entered every time you connect your Trezor device to 3rd party wallet (such as Adalite) and export the public keys (via Trezor Connect).

Hi @radekP,

thank you, I am much more calmer now :slight_smile: