Sign transaction error: session not found Aug 29, 2021•12:28

se ha abierto el Ticket ID: 92400

Thank you for providing us with further details. Sorry to hear you have been experiencing such issues.

Please, are you able to access bootloader mode and Factory reset your device?

See instructions,

Then proceed with firmware installation afterwards, and let us know if there is any progress.

but ¿what about my coins already in accounts?

I send you some images of “terminal bridge” and the frozen T Trezor

Hi Pavel;
I did what you recommended, cleaned the memory and reset all the parameters; however the same error “session not found” keeps occurring; and my trezor T frezzes on “signing transaction”
By the way, I had no problem recovering my accounts.

please, what else can I do?

How long does it take from clicking “hold to confirm” to “session not found”?

is it a couple seconds? minutes?

instantly; as soon as I release (complete) the “hold”.

1 Like

EY!!!; I kept testing and trying to send my coins to my local exchange and it seems that the problem got worse, but what I must say I consider sensitive for Trezor and I don’t think this is the right channel to do it,
how do I communicate it to you?

Sorry, I didn’t get a comment from you, so I am sending you the information of what happened:

I re-installed trezor bridge directly on my computer (I was using it from a flash drive); and tried to perform the sending to my local exchange and oh!!! surprise!!!, it successfully executed all the steps (confrm-hold-signing) in less than two seconds.
However; it did not update my balance in the account (and not in my local exchange either), it is as if my trezor T had performed only a successful “simulation”. Obviously “something” happened with the App “trezor suite” or in my Trezor T that signaled as successful the transaction, but did not actually execute it.
I then tried to repeat the successful event and made a simple transfer from my standard account to a hidden account on my trezor T, I auto-sent the maximum balance and then again the error occurred in Trezor suite: “session not found” and on my trezor T the “Signing Transaction” process circle froze; only now instead of advancing 1/4 of the circle, it advanced just 1/10.

I hope all this information will help you to help me to solve the problem. Thank you.

Hello; today in the morning I tried again to send coins to my local exchange and the “trezor suite” App notified me again the “session not found” error at the moment of starting the “signing transaction” process.

Now I tried again and in the “trezor suite” App I received the “session open in another window” notification and the “signing transaction” circle on the device just 1/20th of the way through; I then disconnected the Trezor T device and reconnected it and tried again to “send” and oh! surprise it worked correctly and even instantly my updated balance appeared in the “trezor suite” App.

Excited I then tried again to send the total of my balance from the standard account to my hidden account and again the usual error occurred: “session not found” and on the device the “signing transaction” circle now advanced 1/4.

It is really very strange, I send you some pictures

I send you another image of the App “trezor suite” where there are differences in the dates reported (red circles), I think it would be a good aesthetic improvement.

Thanks for the info. It seems you are encountering some sort of bug in how Suite interacts with Trezor Bridge.

Please try the following:

  • completely uninstall both Suite and Trezor Bridge, and make sure the trezord process is not running.
  • use Chrome browser to access the web version of Suite at
  • click “Find Trezor” on the welcome screen, pick Trezor from the list offered
  • proceed to Suite and try again

Thanks for the suggestions, I have already done all the steps and the transaction (send my standard wallet to my hidden wallet) worked correctly

but, that means that:

A) I will not be able to use the App “trezor suite” on my desktop? (including your trezor bridge) ???

B) I will have to use chrome browser from now on with ???

I modified your comment to show the link instead of the name :slight_smile:

To answer your questions: It is possible that a future update will fix the problem. It is also possible that if you reinstall Suite now, it will just work. Because we don’t know the cause of the bug, there is no way to be sure. If you feel like it, you could open an issue on – but keep in mind that (a) it is not a support site, (b) you might be expected to provide technical details, and (c) the priority for that bug might be low.

The bridge-less browser version of Suite only works with Chrome browser, so yes, if you keep using the web version of Suite, you will need to use the Chrome browser to do it.

hanks; I understand that you guys are taking care of the problem now, so that’s good enough for me.
I will wait for the fixed version of the “trezor suite” App and in the meantime I will continue to use the bridge-less version in Chrome browser as I need it.

thanks also for the substitution of the name for the link, it is more understandable what we are talking about.

Last question; whata about the ticket 92400 open?

Should you encounter any further issues, please consider using our stable Trezor Wallet Trezor Wallet or Electrum app Apps:Electrum - Trezor Wiki in the meanwhile, before the issue is fixed.

@JoseNieto As for the ticket you submitted, I have just closed it as resolved. In case you have any questions, don’t hesitate to reach out anytime.

Thanks, yes, my transaction was successful via “"web/ but only in Google CHROME browser.

Firefox browser does not support WebUSB (for security reasons), so it requires the trezor bridge (attached image); however; apparently; @Matejcik: “It seems you are encountering some sort of bug in how Suite interacts with Trezor Bridge”.

Therefore: as far as I understand, you are still trying to solve this bug: “freezing during transaction signing process” problem that occurs on the Trezor T device and the simultaneous “session not found” problem in the “trezor suite” App.

So, my inquiry for support has indeed been outstandingly successful. Thank you very much. BUT; the issue is still unsolved and I believe that we users of Trezor T devices should have a smooth operation, taking into account that this is a hardware wallet in which we place 100% of our trust & worthiness (loyalty).

By the way & related, I would like to share with you this link which I think provides a little more information at;

“karelbilek commented on 7 Jul 2020 •
Trezor (a cryptocurrency Hardware wallet) - my former employer - uses WebUSB, when available, for communication with web wallet, if used from a browser. (I wrote the WebUSB code into both the website and the C firmware.)
I think in the next, planned version, they offer Electron app first, which does not use WebUSB, but includes local server in go and c++ (because it’s still easier for debugging to use the raw OS calls), but if you decide to skip Electron app and use web, it goes to WebUSB.
one reason why they plan to push Electron instead of web app is that Firefox doesn’t support WebUSB :slight_smile: "

Thank you and have a great day


Thanks for your insightful and valuable comments, @JoseNieto! :+1: