Cannot find Trezor address in Metamask


Today I used my Trezor wallet to make a new wallet on my metamask account. I sent funds to this wallet and later on I ‘removed’ the wallet from my metamask.

When I tried to login later I couldn’t find the address that I made with Trezor. I do see a lot of other addresses but I can’t find the one that I made with Trezor. I tried to repeat the same process again and this time the addresses that I removed from my metamask where clearly shown.

Please help me out, I can not get access to my wallet since I cannot import the address in metamask… I would like to retrieve acces again to my funds.

Thanks a lot in advance,

Is the eth address of the mm-trezor wallet you created not the eth address on your suite?
If you create a wallet again but cannot find the same address, it is likely that your secret phrase is different from the one you used last time.

Hey, thank you for your reply. The first ETH address that I can choose in my Metamask is the same as the ETH address in my suite. I enclosed a picture of the window where I can choose other addresses. I choose another address and made a wallet with this other address.

I want to add the wallet through the ‘‘add hardware wallet’’ option but it doesn’t seem to show this same address that I added before. I do not need my seed phrase to add this one. Only my pin and passphrase. Or is the passphrase the one that you meant?

Because I didn’t change my Passphrase.

WhatsApp Image 2021-12-15 at 16.18.00|281x500

yes,I didn’t find the translation error in Google Translate this time.

The suggestion I can give you is to install the MM wallet on another browser and try to create an MM-trezor account on that MM. You may find the previous address.
All the wallets I create will use the same addresses that can be found on the suite. The advantage of doing so is that I don’t have these troubles. After all, you can’t fully understand how third-party software works.
If one day there is a compatibility issue due to a version upgrade, I won’t be anxious because I can’t move assets.

Good one, thanks.
I sadly enough did not find the address in the other browser.
I hope there are other ways to fix this problem…
Have already contacted trezor helpdesk…

Sorry to bump up an old forum post, but it seems this problem is an often recurring one.

I too, along with many many other people are encountering this issue. Why does Trezor not make the wallet recovery process more user friendly? I mean, hello, if you hear so many of the exact same issue, maybe it’s time that an easier wallet recovery process be implemented into the code?

I changed into a new PC, and deleted my Brave browser (including of course the Metamask extension inside) on my old PC. I recovered the correct Metamask first address so it shows that I inputed the correct Seed Phrase. Problem is, no matter how many times I uninstall/re-install Metamask, and then connect Trezor One, the wallet with my funds is not appearing.

NO, please don’t suggest I might have inputed the wrong seed. I HAVE ONLY ONE SEED, I wrote it down and put it somewhere safe because that’s what we’re taught. I did not create any other Metamask accounts (but of course there were sub-wallets, some linked to Trezor, some not).

The ones linked to Trezor are the ones not appearing, and this is preposterous since I’m already on Wallet # 1500, and still have not found the wallet that contains my crypto. I’ve also tried Reset on Metamask Advanced Options. I’ve also tried re-installing my Trezor firmware from the official Trezor Github account. NOTHING. So frustrating, this lousy product.


If the process is correct, you can discover your wallet by connecting the same trezor to any mm on any computer.
The problem is with the passphrase. mm just hint that passphrases are sensitive. But many people don’t know why they are sensitive.
Mycelium wallet tips are in place. They prompt, don’t enter anything unless you know exactly what a passphrase is.
Here comes the question. Can you remember what passphrase you set yourself when you first connected mm to create the wallet?

Edit: I resolved my issue. But I’m not sure how. I shut everything down last night in frustration. Today after a fresh reboot, and retracing my steps, the account was listed as it should have been. When all else fails, turn it off and back on again?

I think I’m having a similar issue. I created a new standard address, ETH #2, that is not a hidden wallet and does not require a passphrase. But upon connecting MM and adding hardware wallet, the address does not show. I’ve searched up through the 500’s.

Hey mate

I see you got that issue resolved. I now have the same issue. So you believe just simply restarting your mm account and laptop worked. I have been trying for a few days and cannot see my Trezor Address. Running out of ideas. Any help be gratefully appreciated


Got the same problem as jm11. I have connected the device to an old MM wallet (which I had to abandon because it has been hacked) and since then, I cannot connect my Trezor wallet to my new MM wallet. Tried with 4 different browsers, tried to clear the cache, worked in incognito with the browsers… turned on and off the passphrase from my Trezor wallet… and still, my Trezor wallet is not showing up!
I’m <–> this close to giving up and trying with the competitors because I literally don’t know what else I should do to disconnect the Trezor wallet (or delete the history /data) from my old MM wallet and let the Trezor connect to the new one.
Hope that someone from Trezor can help us with this issue.
Thank you

1 Like