XRP Price - Not Updating in my Suite Dashboard

Hello there,

New to this forum, been using Trezor T model for over a year without any issues and love it, until recently these past few weeks I’ve been noticing a little issue when viewing my account balance within the dashboard of the Trezor Suite.

After logging in and seeing my coins and balance the live price of the coin (on my dashboard) is not updating to the current market prices , as it states that it was last updated 22 days ago (when the price was at around $0.52/£0.43) and it hasn’t updated to the current market price since.

I’m ok with receiving and viewing my coins but I’m unable to see my balance updated in real time to the current market pricing. I haven’t made any transaction out of the Trezor as all I’ve done is accumulated over time.

I’m running the latest suite 22.11.1 update along with the Latest Trezor T firmware version 2.5.3. I’m just unsure if this is something to be concern with, or could it be the network is congested?

I have to attached some photos just so you can get a better understanding. I’ve already sent two messages the same as this one through bug report within my dashborad, but have yet to hear any response back.

I look forward to hearing any responses from you all on this matter, I appreciate any support that comes back.

Kind regards


P.S. I don’t have any other coins in my Trezor account.

Dear friend…
Was this resolved for you?
I have discovered the same issue on Trezor suite…
This has occurred after my first (and only) transaction after sending XRP from Trezor to Binance successfully, yet no price updates are occurring since even though it suggests new updates are occurring…
I also only have XRP on my Trezor portfolio…


Hi @PMSMA247 and @daviddewarenne,

the latest version of Trezor Suite is v23.3.2. You can download it at https://trezor.io/trezor-suite, or you can update it directly in Trezor Suite in “Settings” (the gearwheel symbol in the top right corner of Trezor Suite) under the “Application” tab (“Check for updates”):

Please install the latest version (or update). If the issue persists, try restarting the app: Settings → “Application” tab → “Reset app”

1 Like

Good morning,

I have had the same issue now for >7 days (XRP price is not updating). I’m running the Apple Silicon 23.3.2 version. I have reset the application as well as totally uninstalled and reinstalled the app.

The current price (in the app) shows updated 8 minutes ago, but the current price via coindesk (every time I check) does not reflect in the Trezor app.

I thought it was just a lag, but the app price has not changed in at least 7 days whereas the coindesk (and others) price has changed quite a bit (up/down).

I have checked for network blocks (even took my laptop to another network) as well as tried w/different computers (PC versus Mac) - the results are the same. I have tried the “Reload” as well as the “Force Reload” but the price on the app is never close to the current online price (even accounting for 5-15 minute delay in Trezor app price updates).


We found that there is a small issue with updating the XRP price in Trezor Suite. Our developers are working on a fix. We are sorry for the inconvenience caused!